PCB Design Flow using OrCAD
Capture CIS and PCB Editor 17.2

Learning the Electronics PCB design flow by example

Kirsch Mackey
8-23-2017
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.1</td>
<td>Overview</td>
<td>30</td>
</tr>
<tr>
<td>3.2</td>
<td>Background Information</td>
<td>31</td>
</tr>
<tr>
<td>3.3</td>
<td>Drawing and Simulating the LED Schematic</td>
<td>31</td>
</tr>
<tr>
<td>3.3.1</td>
<td>Placing Parts in OrCAD Capture CIS</td>
<td>31</td>
</tr>
<tr>
<td>3.3.2</td>
<td>Find Any PSPICE Compatible Part</td>
<td>33</td>
</tr>
<tr>
<td>3.3.3</td>
<td>Wiring Parts in OrCAD Capture CIS</td>
<td>35</td>
</tr>
<tr>
<td>3.3.4</td>
<td>Simulating the AMV Circuit</td>
<td>36</td>
</tr>
<tr>
<td>3.4</td>
<td>Preparing the Schematic for Layout</td>
<td>38</td>
</tr>
<tr>
<td>3.4.1</td>
<td>Adding Connectors to the Schematic</td>
<td>39</td>
</tr>
<tr>
<td>3.4.2</td>
<td>Annotating the Parts in the Schematic</td>
<td>41</td>
</tr>
<tr>
<td>3.4.3</td>
<td>Attaching Package Symbols (Footprints) to Parts</td>
<td>43</td>
</tr>
<tr>
<td>3.4.4</td>
<td>Adding Title Text to the Schematic</td>
<td>44</td>
</tr>
<tr>
<td>3.4.5</td>
<td>Setting Up the Printed Circuit Board</td>
<td>45</td>
</tr>
<tr>
<td>3.4.6</td>
<td>Setting Up Footprint and Padstack Search Paths</td>
<td>46</td>
</tr>
<tr>
<td>3.4.7</td>
<td>Creating the Netlist to Update the PC Board</td>
<td>47</td>
</tr>
<tr>
<td>3.5</td>
<td>Setting Up the PCB Editor Environment</td>
<td>49</td>
</tr>
<tr>
<td>3.5.1</td>
<td>Changing Default Text Width</td>
<td>49</td>
</tr>
<tr>
<td>3.5.2</td>
<td>Creating Color Views (Silk screen, Solder mask, Copper and Design Outlines)</td>
<td>50</td>
</tr>
<tr>
<td>3.6</td>
<td>Laying Out the Printed Circuit Board (PCB)</td>
<td>52</td>
</tr>
<tr>
<td>3.6.1</td>
<td>Routing the PCB</td>
<td>54</td>
</tr>
<tr>
<td>3.7</td>
<td>Preparing for Manufacture</td>
<td>59</td>
</tr>
<tr>
<td>3.7.1</td>
<td>Generating Silk screen</td>
<td>59</td>
</tr>
<tr>
<td>3.8</td>
<td>Generating Artwork (Gerber) and Drill Files</td>
<td>64</td>
</tr>
<tr>
<td>3.9</td>
<td>Generating Documentation</td>
<td>66</td>
</tr>
<tr>
<td>3.9.1</td>
<td>Photoplot of PCB Layers</td>
<td>66</td>
</tr>
<tr>
<td>3.9.2</td>
<td>Adding Vendor Information to Parts</td>
<td>67</td>
</tr>
<tr>
<td>3.9.3</td>
<td>Generating a Bill of Materials</td>
<td>68</td>
</tr>
<tr>
<td>3.9.4</td>
<td>Generating a Smart PDF of a Schematic</td>
<td>69</td>
</tr>
<tr>
<td>3.9.5</td>
<td>Generating a Regular PDF of the Schematic</td>
<td>70</td>
</tr>
<tr>
<td>3.10</td>
<td>Submitting Your PCB for Fabrication Check</td>
<td>71</td>
</tr>
</tbody>
</table>
3.10.1 Packaging the Artwork Files ............................................................... 71
3.10.2 How to Submit Artwork (Gerber) Files for Design Review ............... 71
4 Chapter 4 – Learning Capture CIS ............................................................ 75
  4.1 Overview ............................................................................................... 75
  4.2 Finding electronic parts for the schematic ........................................... 75
    4.2.1 Searching Digi-Key parts ............................................................. 76
  4.3 Creating Schematic Symbols in Capture CIS ........................................ 78
    4.3.1 Capture CIS Libraries ................................................................. 78
    4.3.2 Starting a new project ................................................................. 78
    4.3.3 Creating a Schematic symbol library .......................................... 78
    4.3.4 Creating an LED Schematic symbol ............................................ 79
    4.3.5 Placing the LED Schematic symbol ............................................ 83
  4.4 Adding merchant information to parts in Capture CIS ......................... 83
5 Chapter 5 – Learning PCB Editor ............................................................. 85
  5.1 Resources and Materials ................................................................. 85
  5.2 Footprint Creation Process Overview ................................................ 85
    5.2.1 Introduction to Package Symbols .................................................. 85
  5.3 What types of component packages exist? ......................................... 86
    5.3.1 Overall Process ............................................................................. 87
  5.4 Retrieving Package Symbol Information from Datasheets .................... 87
    5.4.1 How to read a datasheet for a package symbol (footprint) .......... 87
    5.4.2 What to look for in the datasheet ................................................. 88
    5.4.3 Measurements in the datasheet .................................................... 89
  5.5 Incorporating Datasheet Information into PCB Editor Package Symbol Wizard ........... 90
    5.5.1 Starting a new package symbol creation ..................................... 90
    5.5.2 Setting up the package symbol parameters ................................ 90
    5.5.3 Package dimensions and Parameters from the datasheet .......... 90
    5.5.4 Selecting padstacks based on the datasheet ................................. 92
  5.6 Making Through-Hole Package Symbols (Footprints) .......................... 94
    5.6.1 Using Package Symbol Wizard and Padstack Editor .................... 94
    5.6.2 What the footprints are for .......................................................... 94
5.6.3 Creating Thru Pin Padstacks with Padstack Editor ........................................... 98
5.6.4 TH Discrete in Package Symbol Wizard .............................................................. 99
5.6.5 Single In-line Package (SIP) in Package Symbol Wizard .................................. 100
5.6.6 Zig-Zag In-line Package (ZIP) for Through-hole Footprints ............................ 111
5.6.7 Dual In-Line Package (DIP) for Through-hole Integrated Circuits (ICs) ............ 113

5.7 Making Surface Mount Package Symbols (Footprints) ........................................ 114
5.7.1 Zig-Zag In-line Package (ZIP) for Surface Mount Package Symbols (Footprints) 114
5.7.2 Creating Surface Mount Padstacks with Padstack Editor .................................. 116
5.7.3 SMD Discrete in Package Symbol Wizard .......................................................... 117

6 Building and Testing the PCB ..................................................................................... 120
6.1 Overview ................................................................................................................ 120
6.2 Populating the PCB ................................................................................................. 121
6.2.1 Setting up your station and prepping your PCB ................................................. 121
6.2.2 Which order to place the parts .......................................................................... 121
6.2.3 Soldering the parts ............................................................................................ 121
6.3 Testing the PCB ...................................................................................................... 122
6.3.1 Test using a digital multi-meter ........................................................................ 122
6.3.2 Test using a power supply ................................................................................. 122
6.3.3 Test using an oscilloscope ................................................................................. 123
6.4 Documenting the Results ....................................................................................... 124
6.4.1 Taking pictures of the PCB ................................................................................. 124
6.4.2 Placing pictures in a report ................................................................................ 124
6.4.3 Formatting the report ......................................................................................... 124

7 References .................................................................................................................. 125
Objectives

1. Understand what a printed circuit board is
2. Learn how a printed circuit board is fabricated.
3. Understand how Capture CIS and PCB Editor help in the PCB fab process.

Purpose of the Tutorial

Welcome to the PCB Design Flow using OrCAD Capture CIS and PCB Editor 17.2 Tutorial. The purpose of this tutorial is so you learn how to use industry leading software to create electronics and printed circuit board (PCB) designs from concept to prototype.

You will be given objectives at the beginning of each chapter so you know what to expect to gain. Then the end of each chapter will have a summary of lessons and skills learned.
What are OrCAD Capture and Allegro PCB Editor and who uses them?
OrCAD Capture and Allegro PCB Editor are made and managed by Cadence Design Systems. It is one of the leading industry software programs in the United States for PCB design flow. Companies that use the Cadence suite include (but are not limited to):

- Apple Inc.
- Cadence Design Systems
- Intel
- IBM

By understanding the design flow, you will be better equipped to speak with hardware design engineers about electronics engineering and PCB design.

Who is this Tutorial for?
This tutorial is written for sophomore, junior and senior undergraduate students with previous schematic and simulation experience using OrCAD Capture and PSpice. Nonetheless, the reader will be given a refresher on the OrCAD suite by going through the tutorials in this document.

This chapter introduces the PCB design and fabrication process and how OrCAD and PCB Editor are used to create PCB designs. For more information, read Complete PCB Design Using OrCAD Capture and PCB Editor by Kraig Mitzner [1].

1.1 Computer-Aided Design and OrCAD
Computer Aided Design (CAD) describes the use of software and computer tools to execute a design idea.

As shown earlier, OrCAD Capture and Allegro PCB Editor are some of the choice software programs used by top companies to design complex we use today. The OrCAD suite has been known to have a high learning curve but is one of the most powerful electronics drawing and PCB design software programs available.

1.1.1 The role of OrCAD Capture
The electronics engineer would still understand the design of a circuit by working through theoretical calculations and drawing it by hand first. Then he or she would take the rough draft drawings to the OrCAD Capture design tool and create a more professional set of drawings for clients and other members of his/her engineering team.

1.1.2 The role of PCB Editor
After creating a circuit concept, then drawing the schematic in OrCAD’s Capture CIS software, the design is imported to Allegro PCB Editor, another tool that interprets the circuit drawing into a real-world physical drawing, known as an Artwork (Gerber) file. The Artwork files use X and Y coordinate instructions to describe how to fabricate the printed circuit board.

Note: You can open artwork files in a simple text editor and read the instruction codes.
There are two methods to get the board fabricated. In the first method, the engineer would send drawings of the PCB to a manufacturer for fabrication. In the second method, the engineer would fabricate the board himself. In this guide, we’ll show you how to send your PCB to a manufacturer.

1.2 Printed Circuit Board Fabrication Process
Once you submit your PCB to a manufacturer, the company will fabricate your board, then return it to you. Afterward, you can populate it with your own circuit components and test your design. We’ll explain how the boards are made in the manufacturing facility.

1.2.1 PCB Cores and Layer Stack up
First, what is a PCB and what does it consist of? A PCB normally looks like Figure 1.1. If you have seen a computer’s internal motherboard or inside any electronics device, you have seen this kind of internal circuitry below.

![Image of a custom board with microcontroller circuit](image_url)
Upon closer inspection, the PCB is actually made of layers of metal and non-metal materials shown in Figure 1.2.

For simple boards, there may just be two layers of copper and a single layer of insulating material between them (often FR-4). For most industrial boards, however, there are multiple layers of conductive and non-conductive material.

The process to make circuit boards is very systematic, but pretty straightforward for the most part.

### 1.2.2 PCB Fabrication Process

**Chemical Etching** - The electrically conductive layers of the PCB (usually made of copper) have their traces selectively routed out by way of acid or mechanical etching. Acid etching is the most popular method, especially to make multiple PCBs.

**Mechanical Etching** – This method uses tools that rotate at very high speeds that route out unwanted copper from the PCB’s layers to just leave the traces behind. The Electrical Engineering department at the University of Arkansas has a milling machine that uses various tools to mechanically etch away areas of copper. This video shows mechanical etching of a PCB.

You will use PCB Editor to create the blueprints that tell the manufacturing house where to etch out the traces and patterns. For more information on the detailed process of PCB fabrication, refer to [1].

### 1.3 Function of Allegro PCB Editor in the PCB Design Process

The Figure 1.3 below shows a graphical representation of how PCB Editor is part of this process.
PSpice and Capture model the electrical characteristics and drawing characteristics of the components that would go on a PCB, respectively. PCB Editor is responsible for mapping the physical dimensions of that component onto the printed circuit board in terms of what’s called footprints. You will learn that footprints are made of some dimensions and use ‘padstacks’ later in the tutorial chapters 2 through 5.

1.4 Design Files Made by PCB Editor

So, what exactly are the artwork files made in PCB Editor that describe the layers made in the PCB layer process? Those files are shown in Table 1.1 with a brief description of what each file represents.

<table>
<thead>
<tr>
<th>Artwork File name generated by PCB Editor Designer</th>
<th>Associated PCB Layer</th>
</tr>
</thead>
<tbody>
<tr>
<td>TOP.art</td>
<td>Top layer (copper)</td>
</tr>
<tr>
<td>BOTTOM.art</td>
<td>Bottom layer (copper)</td>
</tr>
<tr>
<td>Silkscreen_Top.art</td>
<td>Top silk screen</td>
</tr>
<tr>
<td>Soldermask_Top.art</td>
<td>Top solder mask</td>
</tr>
<tr>
<td>Soldermask_Bottom.art</td>
<td>Bottom solder mask</td>
</tr>
<tr>
<td>Solderpaste_Top.art</td>
<td>Top solder paste</td>
</tr>
<tr>
<td>Outline</td>
<td>Board outline</td>
</tr>
<tr>
<td>Project-name.drl</td>
<td>Drill File</td>
</tr>
</tbody>
</table>


Skills and Lessons Learned

In this chapter, you learned the following:

1. What is OrCAD Capture and why it’s important
2. What is PCB Editor and how it is used in the PCB design process
3. The process used to create PCBs like ones found predominantly in consumer electronics
2 Chapter 2 – PCB Design Example

THE PCB DESIGN FLOW BY EXAMPLE

Objectives

1. Become familiar with OrCAD Capture CIS schematic creation.
2. Understand how to take a circuit schematic from drawing to a layout.
3. Learn the engineering design flow process for printed circuit boards.

2.1 Drawing and Simulating the LED Schematic

In this chapter, you will go through the entire design flow by making your first PCB design. The design is a simple resistor, LED and power connectors. Once you draw the design in Capture CIS, you will make the PCB in PCB Editor then submit the artwork files online for review. The LED circuit will maintain steady voltage and stay lit as long as it’s connected to a power source.

2.1.1 Placing Parts in OrCAD Capture CIS

You will use Capture CIS to model the circuit drawings and behavior. Open OrCAD Capture by going to the Windows Start button:

Go to All Programs → Cadence Release 17.2 → Allegro Products → Capture CIS, then when prompted, choose the first Allegro design product (Allegro PCB Design CIS L) and choose OK. A new window will open and you will be ready to start. When the software is done opening, go to:
1. **File → New → Project…** and the **New Project** window appears.

2. Click **Browse** then a Windows Explorer window will appear.

3. Navigate to a folder either on the computer OR on your eleg-storage drive (usually found on drive L:).

4. Create a new folder for your project named “LED_yourusername” (where “yourusername” = your University of Arkansas username without the @uark.edu).

5. Highlight the folder you just created, then click **Select Folder**.

6. Inside the **Name** field, type “LED_yourusername”.

7. Under **Create a New Project Using**, choose **PSpice Analog or Mixed A/D**. Then click **OK**.

8. If prompted, choose to **Create a Blank project** (NOT from a template) and click **OK**.

9. A new window appears that has your project loaded.

![Cadence window](image)

**Figure 2.1 Place Part Icon and Window**

Type “P” to bring up the Place Parts Window. You can also Go to Menu → Place → Part...

10. You may be at the schematic page or at the project window tab. If you are on the schematic page proceed to the next step.

**How to open the schematic page:** If you are not on the schematic page for your new project, click on the project tab labeled **LED_yourusername**, then you will see the project file hierarchy. First, expand the following items by double-clicking on each: 

   - `\led_yourusername.dsn` → `SCHEMATIC1`. Then double-click `PAGE1` to open the schematic page.
11. Now you will place some electronic components by clicking on the Place symbol image in the quick access toolbar to the right, shown in Figure 2.1.

12. Click inside the Part field, then type “VDC” then hit the Enter key. In case VDC doesn’t show up, follow the troubleshooting instructions below.

**How to solve missing PSpice libraries/components problem:** You will need to click on the Add Library button under the Libraries: section of the Place Part window. When you click the Add Library button, Windows File Explorer will appear.

Navigate to C:\Cadence\SPB_17.2\tools\capture\library\PSpice\ then type Ctrl + A to select everything, then click the Open button. The Libraries: section will load all the libraries and they’ll all be highlighted in blue. When finished, the libraries and VDC will show in the search field.

13. Click inside the Part search box where you typed “VDC”, then press Enter. The component will attach to your mouse cursor (wait about 5 seconds if nothing is happening).

14. Use the mouse to click and place the VDC component onto the schematic page.

15. To place a resistor, repeat the previous steps by typing “R” into the Part search box in the Place Part window, pressing the Enter key for it to attach to your cursor.

16. Press the R key to rotate the resistor so it’s vertical, then click to place the resistor on the page.

17. Once you have placed the resistor, you need to place a ground. Search for the ground symbol on the quick access toolbar on the right of the OrCAD Capture window area and click on it, then the Place Ground window will appear.

18. Highlight “0/CAPSYM” in the list, then click OK. The ground symbol will attach to your cursor.

19. Place the ground symbol onto the schematic, then right click → End Mode.

Now you are going to place the LED.
2.1.2 Find Any PSPICE Compatible Part

This section will show you how to search for a part that can be simulated in PSPICE if you don’t know its part number. We’ll perform this search with a light emitting diode (LED).

1. In Capture CIS menu, click on Place → PSpice component… → Search…, then the PSpice Part Search window will appear.

2. Click OptoElectronics → LEDs → 5 mm(T1 0.75) Package → Amber (2Parts). Notice the parts that appear in the list below under PART NAME and DESCRIPTION.

3. Double click on the first part inside the list and it will attach to your cursor.

4. Move the part onto the schematic area, pressing the R key to rotate the component until it’s pointing downward, and place it where you like.

5. Now, click-drag the components along the schematic until they look like in Figure 2.2.

![Figure 2.2 Unwired LED Circuit](image)

This simple circuit is used for simulation in PSPICE

2.1.3 Wiring Parts in OrCAD Capture CIS

1. Click on the Place Wire (W) button on the Quick Access toolbar to get into wiring mode.

2. Click on the ends of the circuit components to start and terminate wire connections, wiring the components together until they look similar to Figure 2.3, then right click and choose End Wire.

**Tip:** Make sure to click-release when connecting the wire from one component leg/lead/wire to another component leg/lead/wire. If you click-hold and drag the wire, you will get bad connections.

3. Double click on the text next to the LED that says LA_541B-TYP, to have the Display Properties window appear.

4. Change the Display Format to Do Not Display, then click OK.
5. Next, change the resistor text value from “1k” to “500” by double-clicking on the “1k” value to bring up the Display Properties window, then typing “500” into the Value field, then clicking OK.

6. Repeat the previous step on the VDC part to change the “0VDC” value to “9VDC”.

7. Finally, go to the Capture CIS menu then click File → Save and save your project.

Your schematic should look like Figure 2.3.

Figure 2.3 Wired LED Circuit

2.1.4 Simulating the LED Circuit

1. Go to the menu in OrCAD Capture CIS and choose PSpice → New Simulation Profile..., then the New Simulation window will appear.

2. In the Name field, type “transient” for example, then click Create.

3. There will be a short wait until PSpice shows up on the Windows task bar.

4. Click on that software icon and a Cadence Product Choices window will appear.

5. Select the first product “Allegro PSpice Simulator”, then click OK. The Simulation Settings window will appear.

6. In the Simulation Settings window, change the Run to time field value to “1” (second) then change the Maximum step size to “0.001”.

7. Click Apply then click OK.

8. Go to the menu PSpice → Markers → Voltage Differential. The voltage differential marker will attach to your mouse cursor.
9. Click and place the first marker on the node (line) between the resistor and LED, then place the second marker on the node between the 0 Ground and Resistor, then right click and choose **End Mode**. Your schematic should look like **Figure 2.4**.

![Figure 2.4 LED Circuit with Differential Probe Markers](image)

10. Finally, go to menu **PSpice → Run**. You may need to click the PSpice icon that appears on the Windows Task Bar to see the simulation waveform.

11. The simulation will show a green line to indicate the voltage difference between the voltage probes over a 1 second period of time. The waveform should look the same shown in **Figure 2.5**.

![Figure 2.5 Simulation of LED Circuit Resistor Voltage](image)

## 2.2 Preparing the Schematic for Layout

Now that your simulation works, you will prepare the circuit for board layout. You will learn how to put the schematic on a new page and add some connectors that would be used on a physical board. In OrCAD Capture CIS:
1. Close any simulation windows you may have open.

2. Save this LED\_yourusername schematic by going to and clicking File → Save. Make sure to save the project frequently.

3. Click on the Project tab among the window tabs in Capture CIS. You will see the field hierarchy for the project.

4. Then in the project hierarchy, right click on the project file ending in “.dsn” extension (for example, LED\_yourusername.dsn, and then select “New Schematic”. A New Schematic window prompt will appear.

5. In the Name field, type LEDSCH\_yourusername, then click OK and a new folder LED\_yourusername will be created in the file hierarchy.

6. After the LED\_yourusername folder is created, right click on it → choose New Page.

7. In the Name field, type LEDSCH\_yourusername, click OK, then an LEDSCH\_yourusername* file will be created below the LEDSCH\_yourusername folder.

8. Double-click the previous schematic page (should be named PAGE1 under the folder SCHEMATI), click and drag your mouse cursor across the components, to highlight all of them.

9. Right click the work area then select Copy (or Ctrl+C).

10. Click on the Project tab again (labeled LED\_yourusername) then double-click on the page named “LEDSCH\_yourusername”, under the folder named “LEDSCH\_yourusername”. The blank schematic page will appear.

11. Right click on this new blank work area → select Paste (or type Ctrl+V).

The new schematic is now placed.

### 2.2.1 Adding Connectors to the Schematic

Now that you have copied the simulation schematic to the layout schematic, you need to replace the VDC with two real-world connectors - one for power and one for ground.

1. So press P on the keyboard to open the Place Part window.

2. Then in the Part search box type “con1”, then press Enter on your keyboard. The part should attach to your cursor (if it doesn’t, see below) and you can place it on the schematic.

**How to solve missing libraries/components problem:** You will need to click on the Add Library button in the Part Add section of OrCAD PCB Editor. Navigate to C:\Cadence\SPB\17.2\tools\capture\library then type Ctrl+A on the keyboard to select all Files in
that folder, then click the **Open** button. You only needed to add the library named CONNECTOR.OLB, but it’s best to add all the libraries anyway. The libraries and connector library will show up in the Libraries: window section.

3. Place the CON1 component such that its connector leg (red pin) connects to the VDC positive terminal on the schematic. A good connection is indicated by a pink circle and the connection point.

4. Search for the “con1” part and place a second copy of it on the negative terminal of VDC.

5. Right click on the schematic page → click **End Mode**.

6. Click the VDC part → then press the **Delete/Backspace** key to delete it. Then your schematic would look similar to Figure 2.6.

7. If the CON1 blocks aren’t connected to the wiring, select the **Place Wire** tool (or press W), then wire the CON1 to the top of the LED, where the positive end of the VDC used to be connected.

8. Repeat the previous step to connect a second CON1 part to the bottom of the circuit, where the negative VDC terminal used to be connected.

Your circuit should look similar to Figure 2.6. Now you are ready to associate footprints with the components and prepare them for printed circuit board layout.

![Figure 2.6 LED Circuit with Power and Ground Connectors](image)

**Figure 2.6 LED Circuit with Power and Ground Connectors**

The connectors replace the +ve and -ve VDC because the VDC part was only for simulation

### 2.2.2 Attaching Footprints to Schematic Parts

You are going to match circuit package symbols (footprints) with parts from your schematic.

1. Click and drag the mouse across all the components to highlight them.

2. Go to menu **Edit → Properties**... (or press Ctrl+E).

3. Click on the Parts tab near the bottom left of the window.
4. Scroll to the **PCB Footprint** column field at the top of this window. Notice that there's a footprint name that's already preloaded for R1 (you will see the name R1 in the **Part Reference** column next to **PCB Footprint**), named “AX/RC05”.

5. Delete that footprint value (using the Delete key) and type in “res400” instead.

6. In the field for D1, type or copy/paste “RAD100X050LS100031”.

7. For the remaining parts, J1 and J2, type “jumper1” into each of their **PCB Footprint** fields.

8. Go to **File → Save**, to save the project.

9. Click the **Project tab** → right click on the folder “LEDSCH_yourusername” and choose **Make Root**, then you will see the PCB folder jump to the top of the hierarchy.

10. Finally, go to **File → Save**, to save your project again.

### 2.2.3 Setting Up the Printed Circuit Board in PCB Editor

1. Go to the Windows Start menu icon, then click All Programs → Cadence Release 17.2 → Allegro Products → PCB Editor.

2. When prompted, choose Allegro PCB Designer then click OK.

3. Wait for **PCB Editor** to open.

4. Click on the **PCB Editor** menu **File → New**. A **New Drawing** window appears.

5. Choose **Board (wizard)** from the list, then name the drawing “LEDPCB_yourusername”.

6. Click the **Browse** button, then navigate to your project folder (LED_yourusername).

7. Create a new folder inside the LED project folder and name the new folder “allegro” (all lowercase).

8. Double-click the allegro folder to open it, then finally, click the **Open** button.

9. Back in the **New Drawing** window, make sure **Board (wizard)** is still highlighted, and that your board name is correct (LEDPCB_yourusername.brd), then click **OK**. The Board Wizard will then appear.

10. Click the **Next** button until you get the **Board Wizard – General Parameters** window (shown at the top bar of your window).

11. Choose the **Units** to be Mils, **Size** set to A and choose the “At the center of the drawing” radio button. Click **Next**.

12. In the **General Parameters (Continued)** window, leave the settings as they are, but select the “Don’t generate artwork films.” radio button. Click **Next**.
13. Click **Next** to get past this **Etch Cross-section details** window and go to the **Spacing Constraints** window.

14. Type 12 in the Minimum Line width then press Tab key. Everything will update to 12 mils.

15. Then select the ellipses next to **Default via padstack** and a new window will appear.

16. In the **Board Wizard Padstack Browser**, type “pad35*” in the search field, then press Enter on the keyboard.

17. Select “pad35cir25d” on the list below → click **OK**.

18. You will be back in the **Board Wizard – Spacing Constraints** window. Click **Next**.

19. Choose **Rectangular board** then click **Next**.

20. Leave the default values as they are. The **Width** and **Height** of the board will be 1000 mils each (1 inch each).

21. Click **Next → Finish**. The board will be made in the work area and should look like Figure 2.7. Scroll your mouse wheel down to zoom out if you are not able to see its outline.

22. Close the **PCB Editor** software and click **Yes** to save if prompted.

![Figure 2.7 PCB Outline for LED Circuit](image)

**2.2.4 Creating the Netlist to Update the PC Board**

Now you are ready to update the board you just made in **PCB Editor**. You will translate the schematic from Capture CIS into circuit symbols that can be placed onto the PCB in **PCB Editor**.
1. Close PCB Editor if you still have it open. Choose **Yes** if asked to save changes.

2. Go back to OrCAD Capture CIS if it’s already open **OR** if it’s closed, Go to Windows Start → All Programs → Cadence Release 17.2 → Allegro Products → Capture CIS, choose the first product option, then click **OK**.

3. Open your project from **File → Open → Project**, then find your project and open it.

4. When your project is open, click on the Project Tab → expand the project file named “LED_yourusername.dsn” → select the **LEDSCH_yourusername** folder → select the **LEDSCH_yourusername** page.

5. While the file (LEDSCH_yourusername) in the hierarchy is selected/highlighted, go to menu **Tools → Create Netlist...**, then a new window will appear.

6. Check mark the option that says **Create or Update PCB Editor Board (Netrev)**.

7. Choose the **Input board** to be the one you just created (it’s found in your project folder then inside the “allegro” folder you made earlier > LEDPCB_yourusername.brd).

8. Then change the output board to the same name “LEDPCB_yourusername.brd”.

9. Make sure the settings and options are set to as shown in **Figure 2.8**. Then click **OK**.

10. If a prompt appears, click **Okay** then the net list will be generated and **Capture CIS** will automatically open PCB Editor. A Cadence 17.2 Allegro Product Choices window will appear, asking which product to use.

11. Select the first option: Allegro PCB Designer, then click OK. The board will be opened in PCB Editor. We recommend saving your PCB before moving on.
2.3 Laying Out the Printed Circuit Board (PCB)

Now it’s time to lay out the printed circuit board in PCB Editor. If you don’t recall how to open PCB Editor, Go to Windows Start → All Programs → Cadence Release 17.2 → Allegro Products → PCB Editor, choose the Allegro PCB Designer option, then click OK and PCB Editor will open.

1. In PCB Editor, Go to the menu: Place → Manually…, the Placement window appears.
2. Choose in the dropdown field on the left “Component by refdes”.
3. Below the dropdown bar, check mark all the components by clicking in the box beside “Components by refdes”.
4. Click the Hide button at the bottom of the window and a part will attach to your cursor.
5. Click the work area to place each component that’s attached to your cursor. You can right click then choose Rotate to rotate each part before you place the part.

! How to Rotate a Part: To rotate a part, right click when the part is still attached to your cursor and is floating, then a dropdown menu will show up. Click Rotate then the part will
stop moving and will begin rotating depending on which angle you move your cursor. When you have decided which angle you want, click once, then the part will re-attach itself to your mouse cursor and you can place the newly rotated part by clicking once on the work area.

6. If you place a part by mistake, click-release (do not drag) the part to pick it up, then move it anywhere you like, then click once to place the part in some location.

7. Once the components have been placed like in Figure 2.9, right click the work area and select Done (shortcut F6).

![Figure 2.9 LCB PCB Components Placed](image)

Connectors are on the right of the board for power. The left side of the PCB has the signal.

### 2.3.1 Routing the PCB

1. In PCB Editor, Go to the menu **Route** → **PCB Router** → **Route Automatic**…. The **Automatic Router** window will appear.

2. Click the **Route** button. The PCB will automatically be routed.

3. Click **Close** and then save your design by going to **File** → **Save**, then select **Yes** when asked to overwrite the pre-existing File.

**Note:** Sometimes the PCB can suddenly disappear into all black. To solve this problem, minimize PCB Editor, then maximize it or scroll up/down in the work area.

### 2.3.2 Generating Artwork (Gerber) and Drill Files

**Generating Artwork (Gerber) Files**

1. In **PCB Editor**, Go to **Manufacture** → **Artwork**… The **Artwork Control Form** window will open.

2. Check mark **BOTTOM** and **TOP**. These are called film folders.

3. Highlight the **TOP** film folder name, then change its **Undefined line width** value (on the right) to 5 (mil).
4. Also set the **Undefined line width** to 5 for the BOTTOM film folder.

5. Click the **Create Artwork** button. It’s okay if you get errors/warnings. Just delete the **View of file: photoplot** window if one appears.

6. Then back in the **Artwork Control Form** window, click the **OK** button at the bottom. The Artwork Files will be generated and placed in your “allegro” folder.

### Generating a Drill File

You have made the artwork files, now generate the drill file to indicate where to drill holes.

1. In **PCB Editor** go to menu **Manufacture → NC → NC Drill**. The **NC Drill** window will open.

2. Click the **NC Parameters…** button to open the **NC Parameters** window.

3. Checkmark ☑ **Leading zero suppression** and ☑ **Enhanced Excellon Format**, then click **Close**.

4. Back in the **NC Drill** window, change the scale factor to 1. Check **Auto tool select** and **Optimize drill head travel**, leaving the other two boxes unchecked (especially uncheck Repeat codes).

5. Change the Root File name to LEDPCB_yourusername.drl.

6. Click the drill button, then a drill File will be generated in your “allegro” folder.

7. After the drill file has been generated, click **Close** in the **NC Drill** window.

### 2.4 Generating Documentation

Artwork generation is finished. Now you are ready to submit some documentation and send the board files in for fabrication review.

#### 2.4.1 Photoplot of PCB Layers

1. In **PCB Editor** go to menu **File → Plot Setup**. The **Plot Setup** window will open.

2. Set **Plot scaling** to “Fit to page”, **Plot method** to “Color”, **Plot contents** to “Screen contents”, then click **OK**.

3. In **PCB Editor** go to menu **File → Plot**. The **Print** window will appear.

4. Click the **Setup** button and the **Print Setup** window will open.

5. You may choose a printer you prefer, but for this tutorial, we’ll go with CutePDF Writer.

**Important Note:** If you are doing this tutorial on Blackmesa, use CutePDF, not the option that says CutePDF (redirected 69), because the CutePDF option will print to the Blackmesa computer if you are using Blackmesa, while CutePDF (redirected 69) will not.

6. Click **OK** to close the Print Setup window and you will be back in the **Print** window.
7. Click **OK** to start the print operation. Wait for a few moments.

**Note:** If CutePDF is taking too long to start, click once in the work area of PCB Editor (black area), the CutePDF icon should show in the Windows Task Bar.

8. Click the CutePDF icon to view the **Save As** window.

9. Within the Save As window, navigate to your project folder (LED_yourusername), then create a new folder named Documentation.

10. Navigate to the inside of the Documentation folder, name the File “LEDPCB_yourusername”.

11. Click the **Save** button to save the printout file.

12. In Windows File Explorer, navigate to your project folder and double-check your LED PCB schematic plot File (.pdf File) and make sure that it shows all the PCB layers. Your figure should look similar to what’s on the right.

### 2.4.2 Creating a Smart PDF

1. Open OrCAD **Capture CIS** and open your project in **Capture CIS** if it’s not already open.

2. Click on the Project tab that says “LED_yourusername” to show your project Files.

3. Expand the “led_yourusername.dsn” folder and LEDSCH_yourusername folder.

4. Click and highlight your schematic you created the netlist from earlier (“LEDSCH_yourusername” in this case).

**Important Note:** The schematic file LEDSCH_yourusername must be highlighted before generating the PDF, else the smart PDF won’t know which page you want to print. Also, you should have ghostscript installed on your machine.

5. Click on the menu **File → Export → PDF** and the **PDF Export** window will appear.

6. Under the **Postscript Commands** section, choose the **Converter** to be “Ghostscript 64 bit/equivalent” (or to “Acrobat Distiller” if using Blackmesa).

7. In the **Converter Path** field, click the ellipses button to open the Select Converter window, and navigate to “c:\program files\gs\gs9.21\bin\gswin64c.exe” (if using Blackmesa, choose “c:\program Files (x86)\adobe\acrobat 11.0\acrobat\acrodist.exe”). Then click **Open** to confirm the directory. You will notice the text at the PDF Export window Go from red to green.
8. For the **Output Directory** field, under **Output Properties** section, click on the ellipses button to open the **Select Folder** window.

9. Navigate to the “Documentation” folder you created earlier and choose **Select Folder**.

10. When those options are finished and your PDF Export window looks similar to **Figure 2.10**, click **OK**.

11. The PDF will be generated and will open automatically in **Adobe Acrobat/Reader**. This PDF is “smart” because you can click on each component to see its properties and if you click on the bookmarks on the left you jump directly to that component on the sheet.

12. Close the smart PDF.

![Figure 2.10 PDF Export Settings for Smart PDF](image.png)
2.4.3 Generating a Bill of Materials

1. In Capture CIS, Click on the Project tab and then click/highlight the page schematic you want to create a bill of materials for.
2. Click menu Tools → Bill of Materials and the Bill of Materials window appears.
3. In the Scope section, select Process selection.
4. Check mark Open in Excel.
5. Click the Browse button, then navigate to the Documentation folder that you created earlier, name the file “BOM_LED_yourusername” and click the Open button.
6. Name the file BOM_LED_yourusername, then click Open to confirm the file name and the directory.
7. Back in the Bill of Materials window, click OK, then Excel will open and present a list of all the components in your schematic.
8. In Excel, choose File → Save As → Browse and the Save As window will appear.
9. You should be in the Documentation folder already. Select the Save as type: dropdown bar where it says “Text (Tab delimited)” and change it to Excel Workbook (*.xlsx) instead.
10. Name the file BOM_LED_yourusername again, then click the Save button. Choose Yes if prompted to replace the existing file, then close Excel.

2.5 Submitting Your PCB for Fabrication Check

2.5.1 Packaging the Artwork Files

1. In Windows File Explorer, go to the artwork (.ART) Files you created earlier, located in “[Folder LED_yourusername]\allegro\”.
2. While holding the Ctrl key on the keyboard, select all the Files with extension “.ART” (not .ART-1) and .DRL.
3. Right click the highlighted Files. Choose Send to →Compressed (Zipped) Folder. The .ZIP File will be generated. I will have an arbitrary name, .zip, and extension.
4. Click on the zip File that is generated and change it to LEDART_yourusername.

2.5.2 How to Submit Artwork (Gerber) Files for Design Review

Now you are going to submit your Gerber Files to http://freeDFM.com for PCB review.

1. Open up a web browser (Chrome, Firefox, Microsoft Edge, etc.) and go to freeDFM.com.
2. Type in your University of Arkansas email address in the appropriate web forms.
3. Click the **Browse**... button and then navigate to the “LEDART_yourusername.zip” file that you just created.

4. Select the zip file, and then click **Open**, then the zip file will be placed inside the web form.

5. Click the **Upload ZipFile** button. A new webpage will load.

6. Next, choose the layer types by setting BOTTOM.art as **Bottom Copper** and TOP.art as **Top Copper** in the dropdown menus.

7. The LEDPCB_yourusername-1-2.drl File will automatically be assigned as **NC Drill**.

8. Input all the requested information:
   - Part #: type “LEDyourusername1inx1in.
   - Revision #: 1
   - Layer Count: 2
   - X Dimension: 1,
   - Y Dimension: 1
   - Solder mask Sides: None
   - Silk screen Sides: None

9. Finally click the **No** radio button [No] for the ITAR option (found to the right of the **Quantities** section at the bottom of the page).

10. Double check that your settings are similar to those shown in **Figure 2.11**, then click **Submit**.

    The free DFM quote will be submitted. Just wait 10 to 30 minutes and you will receive results for your PCB via email.
Excellent job! You just finished your first printed circuit board design. The next chapter will cover a more complex printed circuit board design. The PCB is simple but you will gain experience creating a variety of footprints. In addition, you will learn how to create the footprints components from scratch.

**Skills and Lessons Learned**

In this chapter, you learned the following:

1. The entire electronics to PCB engineering design flow process
2. How to create a circuit schematic in OrCAD Capture, and a PCB in Allegro PCB Editor
3. How to generate a bill of materials, generate PCB Artwork and order a PCB DFM check.
CREATING AN ASTABLE MULTIVIBRATOR

Astable multivibrator circuit taken from [6]

Objectives

1. Create and simulate a schematic in OrCAD Capture CIS
2. Create and Lay out a printed circuit board in Allegro PCB Editor
3. Generate documentation and submit a PCB for fabrication.

3.1 Overview

In this chapter, you will learn how to create a more complicated PCB than in Chapter 2. You will:

- simulate a schematic that has a varying voltage signal, then
- design the schematic for manufacturing,
- create through-hole and surface mount device footprints using PCB Editor,
- create the net list and set up a PCB environment with various color views,
- manually route the PCB instead of auto-routing it,
- generate silk screen, solder mask and drawing files, and
- submit documentation for your PCB.
3.2 Background Information

Your project is to repeat the PCB Design Flow with an astable multivibrator circuit. The astable multivibrator is a circuit that constantly changes its voltage at a particular frequency and has no known stable voltage level.

In this tutorial, we have chosen a design that oscillates at about 4 Hz. The circuit has 2 light emitting diodes that will each blink at the 4 Hz frequency to indicate that the astable multivibrator is actually oscillating within some voltage range. We chose 4 Hz, because that frequency is slow enough for the human eye to see the lights blinking.

The circuit you build will look similar to Figure 3.1. Now that you know what to expect, let us get started.

![Figure 3.1 3D Model of astable multivibrator](image)

3.3 Drawing and Simulating the LED Schematic

3.3.1 Placing Parts in OrCAD Capture CIS

Open OrCAD Capture by Going to the Windows Start button: Go to All Programs → Cadence Release 17.2 → Allegro Products → Capture CIS. When prompted, choose Allegro PCB Design CIS L then click OK. A new window will open and you will be ready to start. When the software is done opening, go to:

3.3.1.1 Starting a Project in Capture CIS

1. **File** → **New** → Project and a New Project window appears.
2. Click **Browse** then a Windows **File Explorer** window will appear.
3. Navigate to a folder either on the computer, a personal drive OR on your **eleg-storage** drive (usually found on drive L:).
4. Create a new folder for your project named “AMV_yourusername” (where “yourusername” = your University of Arkansas username without the @uark.edu).
5. Go into the new folder, then click the “Select Folder” button for the folder you just created.
6. Back in the **New Project** window in the **Name** field, type “AMV_yourusername”.
7. Then under the **Create a New Project Using** section, choose “PSpice Analog or Mixed A/D”. Then Click **OK**. The **Create PSpice Project** window appears.

8. Choose to **Create a Blank project** (NOT from a template) and click **OK**. **Capture CIS** will load a schematic, ready for you to place and wire the parts.

**Figure 3.2 Place Part Icon and Window**

*Type “P” to bring up the Place Parts Window. You can also Go to Menu → Place → Part...*

### 3.3.1.2 Placing Parts in Capture CIS

1. Place some components by clicking on the Place Symbol found on the quick access toolbar to right of the work area as shown in Figure 3.2. Or select **Place → Part** from the menu.

2. Then click inside the **Part** field, then type “VDC” and hit the **Enter** key. In case VDC doesn’t show up, follow the troubleshooting instructions below.

**How to solve missing PSpice libraries/components problem:** You will need to click on the Add Library button in the Libraries: section of OrCAD PCB Editor (to find the button, Press P to show the Place Part window on the right and look for the Libraries: section in the middle). Navigate to C:\Cadence\SPB_17.2\tools\capture\library\PSpice\ then type Ctrl + A on the keyboard to select all Files in that folder, then click the **Open** button. You only needed to add the library named SOURCE.OLB for the VDC part, but it’s best to add all the libraries anyway. When finished, the libraries and VDC will show in the search field.

3. Use the mouse to click and place the VDC component onto the schematic page.

4. Next you will place 4 resistors onto the schematic page. To place a resistor, repeat the previous two steps by typing “R” into the **Part** field, then Enter key and clicking on the schematic page to place it (type R to rotate the resistors as you place them).
5. Next, place two capacitors onto the schematic. You would type “c” into the search field this time, hit the Enter key on your keyboard, and then click to place two copies of them onto your schematic page.

6. Next you will place a ground symbol. Click the ground symbol on the Quick Access toolbar as shown in the image in the upper right, then the Place Ground window will appear.

7. In the Place Ground window, highlight 0/CAPSYM, then click OK. The ground symbol will attach to your cursor.

8. Place the ground symbol onto the schematic, then right click → End Mode.

9. So far, your schematic page might look like Figure 3.3.

![Figure 3.3 Schematic page placed 4 resistors, 2 capacitors and 1 ground](image)

Now you are going to place the LEDs and transistors.

### 3.3.2 Find Any PSPICE Compatible Part

This section will show you how to search for a part if you don’t know its part number. For an example, you will find a light emitting diode (LED) and place two of them onto the schematic then you will repeat the same process to find and place 2 copies of a transistor. Even though you may not know the model number of the LED, you can find one in the PSpice folders. To place the LED:

1. In Capture CIS menu, click on Place → PSpice component… → Search..., then the PSpice Part Search window will appear.

2. In the PSpice Part Search window that pops up, click OptoElectronics → LEDs → 5 mm(T1 0.75) Package → Amber (2Parts). Notice the parts that appear in the list below.

3. Double click on the first part in the list that appears so it attaches to your cursor.
4. Move the part onto the schematic area, pressing the R key to rotate the component and place 2 copies with the arrow pointing downward. Right click and choose End Mode.

5. Next you will find the MMBT3904 transistor we’ll be using for the circuit. So go back to the PSpice Part Search window that should still be opened and click in the search field then type “MMBT3904” and press Enter.

6. A list will appear in the bottom. Double click on the first part in the list so it’s attached to your cursor.

7. Place two copies of the transistor on the schematic, then right click → End Mode.

8. Now left click on the first transistor you placed (Q1) so it’s highlighted.

9. Then right click on the transistor, then choose Mirror Horizontally.

10. Click-drag the components along the schematic until they look like Figure 3.4.

![Figure 3.4 Unwired LED Circuit](image)

This simple circuit will be used for simulation in PSPICE
3.3.3 Wiring Parts in OrCAD Capture CIS

Now that your components are placed on the schematic page, you can wire them together.

1. Click on the Place Wire (W) button on the quick access toolbar area to get into wiring mode.

2. Click the ends of each component and connect their ends to wire them together until the components are wired like Figure 3.5 and read the tips below for wiring components.

**Note:** Make sure to click-release when connecting a wire from one component leg/lead to another component leg/lead. If you click-hold and drag the wire, you will make bad connections.

**Tip:** If you want to make diagonal connections, then while in wire mode, hold the Shift key before you start a wire and keep holding it down until you click the end point of the wire.

3. When the components are wired, right click the work area and choose End Wire.

4. Double-click the text value for one of the LEDs (starts with “LA_” in the text) and change it to **Do Not Display**, then click **OK**. Repeat this step for the second LED if necessary.

5. Change the two outer resistor values from 1k to 5k by double-clicking on the “1k” value, then typing “5k” into the **Value** field, then clicking **OK**.

6. Change the two inner resistor values to “470k” using the method in step 5.

7. Change the VDC value from “0Vdc” to “9Vdc” and the C1, C2 values from “1n” to “0.47uF”.

8. Double-click and change the MMBT3904 text on the Q1 and Q2 parts to “Do Not Display” in their Display options, respectively.

9. Finally, go to the **Capture CIS** menu and click **File → Save** and save your project.

Your schematic should now look like Figure 3.6.
3.3.4 Simulating the AMV Circuit

1. Go to the menu in Capture CIS and choose PSpice → New Simulation Profile.

2. A New Simulation window will appear. Name the simulation something generic for a time simulation, like “transient”. Then click Create.

3. There will be a short wait until PSpice shows up on the Windows task bar, but when it appears, click the icon.
4. If the **Cadence Product Choices** window appears, select “Allegro PSpice Simulator”, then click OK. The Simulation Settings window will eventually appear.

5. The **Simulation Settings** icon will show up on the Windows Task Bar, so click on it to open the Simulation Settings window.

6. Change the **Run to time** field value to “1” (this is in seconds) and change the **Maximum step size** to “0.001”.

7. Click **Apply** then click **OK**.

8. Go to the menu **PSpice → Markers → Voltage Differential**. The voltage marker will attach to your mouse cursor.

9. Click and place the first marker on the node (line) between the left-side 5k resistor and the left-side capacitor, then place the second marker on the node between the right-side 5k resistor and right-side capacitor, just like in Figure 3.7.

10. Once the probes are placed, right click and choose **End Mode**.

11. Finally, go to the menu **PSpice → Run**. If warnings appear, just select “Do not show this dialog again”, click OK.

12. The simulation will run and open a **PSpice** analysis window or the PSpice icon in the **Windows Task Bar**.
13. Click the icon to see your simulation results. The waveform should look the same shown in Figure 3.8.

![Waveform Image]

Figure 3.8 Simulation of AMV Circuit Resistor Voltage

### 3.4 Preparing the Schematic for Layout

You will need to make a copy of the AMV schematic and place it in a new page, because the circuit needs to have a more realistic representation of the parts that will be connected to the board. This section shows you how to put the schematic on a new page and add some connectors that would be used on a physical PC board. In OrCAD Capture CIS:

1. Close any simulation windows you may have open.
2. Save this AMV_yourusername schematic by going to **File → Save**. Make sure you save your project frequently.
3. Click on the Project tab (in the upper left area above the schematic).
4. Right click on the project file ending in “.dsn” extension, then select “New Schematic”. A **New Schematic** window will appear.
5. In the **Name** field, type “AMVSCH_yourusername”. Click **OK**. A new folder is created.
6. When the folder is created in the project files hierarchy under the Project Tab, right click on the folder (named AMVSCH_yourusername) → choose **New Page**.
7. Name the page AMVSCH_yourusername then click **OK**.
8. Double-click on the previous schematic page in this hierarchy list (should be named PAGE1 under the folder SCHEMATIC1), which will bring up your simulation schematic.
9. Click and drag your mouse cursor across the components, to highlight all of them.
10. Right click the work area then select **Copy** (or Ctrl+C).

11. Click on the Project tab (labeled AMV_yourusername) then double-click on the Page named “AMVSCH_yourusername”, under the folder named “AMVSCH_yourusername”. A new blank schematic page will appear.

12. Right click on this new blank work area → select **Paste** (or type Ctrl+V) and the entire schematic will attach to your cursor.

13. Left click and place the schematic onto the page.

14. Go to **File → Save** to save your project.

### 3.4.1 Adding Connectors to the Schematic

We're going to replace V1 with some connectors, because the V1 block was only for simulation. There will be one connector for power and another connector for ground. You will also need two test points so you can attach oscilloscope probes to see the voltage waveforms after you get your PCB manufactured. Let’s place some connectors and test points:

1. In **Capture CIS**, press P on the keyboard to start to **Place a Part**.
2. Then in the **Place Part** search box type “con1”. The part should appear (if it doesn’t, see below) so you can press Enter and it will attach to your cursor.

#### How to solve missing libraries/components problem:

You will need to click on the Add Library button in the Part Add section of OrCAD PCB Editor. Navigate to C:\Cadence\SPB_17.2\tools\capture\library then type Ctrl+A on the keyboard to select all Files in that folder, then click the **Open** button. You only needed to add the library named CONNECTOR.OLB, but it’s best to add all the libraries anyway. The libraries and connector library will show up in the **Libraries** window section. When the libraries are loaded, make sure they’re all highlighted (Ctrl+A), then continue your part search in the “Place Part” window.

3. Place the CON1 component such that its connector leg connects to the VDC positive terminal on the schematic.
4. Place another copy of CON1 on the negative terminal of VDC.
5. Right click → **End Mode**.
6. Left click the VDC part to make sure it’s highlighted, then → Right Click → **Delete**.
7. If the CON1 blocks aren’t connected to the wiring, select the Place Wire tool (or press W), then wire up the connectors so they’re connected like in Figure 3.9.
8. Repeat steps 1 through 5 with the same process for these part names: “HEADER 2” (x1 copy) and “TEST POINT” (x2 copies), rotating them as necessary and wiring them to match Figure 3.10

9. You may have different part reference names (like R1, J3) for each component, so we’ll correct that in the next section.

10. Go to File → Save to save your project.

**Important Note:** Ensure the header 2 part has its legs pointing downward and that the part is higher than the CON1 connectors. That Header 2 part being at the top of the schematic will give it a consistent reference letter and number to match the rest of this tutorial.
3.4.2 Annotating the Parts in the Schematic

Once you have placed the connectors, headers and test points, you will annotate the parts. You can manually change the part reference numbers one by one, but instead you will do it automatically using the Annotation tool.

1. With your project open in OrCAD Capture CIS go to the Project tab in the upper left area of your window, then click on the AMVSCH_yourusername page.

2. Right click on the folder named “AMVSCH_yourusername” and choose Make Root, then you will see the AMVSCH folder jump to the top of the hierarchy.

3. Select the AMVSCH_yourusername file and make sure it's highlighted in blue.

4. Go to tools → Annotate then under the Action section, select the radio button that says Reset part references to “?” Then select OK.

5. If prompted about annotating and saving your design, click OK.

You will notice that if you click on the Hierarchy tab above your list of files under the project folder, then expand the SCHEMATIC1 list, all of the parts will have question marks after their reference letters. All the reference numbers have been cleared.
6. Still under the Project tab, click on the File tab to pull up your project folders list.

7. Click on the AMVSCH_yourusername page again then go to tools → Annotate then select the radio button that says Incremental reference update then click the OK button, then if prompted about saving the project, click OK.

8. Click the Hierarchy tab again then this time you will notice all the parts have been renamed. If you did the schematic like the one in this tutorial then your 2-position header connector should be J1, your power connector should be J2, and your ground connector should be J3 again just like Figure 3.10.

9. Once you have verified these reference numbers are fixed, go to File → Save to save the project.

3.4.2.1 Remove unnecessary details from the Schematic

The bill of materials and other documentation you will generate will have enough information for someone else to understand the parts. For this reason, you should remove any information that may confuse the reader or make the schematic difficult to read. You would delete the values for some of the parts and also change the value for some of the parts, as well.

1. If you haven’t done so earlier in this chapter, double click on the value field for the D1 and D2 components (starts with “LA”) and choose Do Not Display for each of them then click OK.

2. Change the text value that says “TEST POINT” on TP1 to “Out+” and change TP2’s value to “Out-“.

3. Change the J1 part’s text value to from “HEADER 2” to “Jumper”.

4. If you haven’t done so already, for Q1 and Q2, double-click on each of their respective “MMBT3904” value fields and change each of their options to Do Not Display, just like you did with the LEDs.

5. Change the J2 part’s text value from “CON1” to “PWR” and change J3’s value from “CON1” to “GND”. Then your schematic will look similar to Figure 3.11. Be sure to delete and add wires as needed.
Now you are ready to associate package symbols/footprints with the schematic parts and prepare them for printed circuit board layout.

### 3.4.3 Attaching Package Symbols (Footprints) to Parts

In Chapter 2 – PCB Design Example you learned how to attach package symbols to the parts on the schematic. The package symbols were pre-made, but oftentimes it’s important to design your own package symbols.

In this section, you attach footprints/package symbols to the schematic components, but the package symbols will be created by you from scratch. To make the package symbols, go to Chapter 5 – Learning PCB Editor of this tutorial and follow that chapter until it redirects you back here.

When you return to this section, you will attach the symbols to your schematic parts in Capture CIS. So go Chapter 5 – Learning PCB Editor now.
### 3.4.3.1 Attaching Custom Footprints to Schematic Parts

1. In **Capture CIS** with your project’s AMVSCH_yourusername page open, click and drag the mouse across all the components to highlight all of them.

2. Go to menu **Edit → Properties...** (or press Ctrl+E).

3. Click on the **Parts** tab near the bottom left.

4. Scroll to the **PCB Footprint** column field. Notice that there are footprint names already associated with some of the parts.

5. Delete all PCB Footprint values (using the Delete key) and you will fill in the footprint names from the **Excel Workbook** for this chapter’s AMV tutorial according to the part reference.

6. Enter the footprint names found in the **Excel Workbook** or as shown in **Table 3.1**.

   **IMPORTANT:** First, make sure that you have either created the footprints or downloaded the footprints already for this tutorial. If not, please create them in **Chapter 5 – Learning PCB Editor** or download the footprints and padstacks [here](#). Second, have the footprints and padstacks in a folder named “AMV Footprints and Padstacks” within your project folder. Third, double-check that the footprint names and padstack names are exactly as shown in the **Excel Workbook** provided with this tutorial and shown in **Table 3.1**.

7. You may hit the **Enter** or **Tab** or **Up/Down** keys to update the field when you are done typing in a part’s footprint.

8. When you are finished adding the footprint names, Go to **File → Save**, to save the project.

<table>
<thead>
<tr>
<th>Part Reference</th>
<th>PCB Footprint</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1, R4 (5k resistors)</td>
<td>amv_res_axial</td>
</tr>
<tr>
<td>R2, R3 (470k resistors)</td>
<td>amv_res_1206</td>
</tr>
<tr>
<td>C1</td>
<td>amv_cap_0805</td>
</tr>
<tr>
<td>C2</td>
<td>amv_cap_radial</td>
</tr>
<tr>
<td>Q1</td>
<td>amv_sot-23</td>
</tr>
<tr>
<td>Q2</td>
<td>amv_to-92</td>
</tr>
<tr>
<td>D1, D2</td>
<td>amv_LEDT-1_075</td>
</tr>
<tr>
<td>TP1, TP2 (Out+, Out-)</td>
<td>amv_test_point</td>
</tr>
<tr>
<td>J1 (2-pin header)</td>
<td>amv_header_1x2</td>
</tr>
<tr>
<td>J2, J3 (power, ground)</td>
<td>amv_con1</td>
</tr>
</tbody>
</table>

### 3.4.4 Adding Title Text to the Schematic

1. In **OrCAD Capture CIS**, double-click the AMVSCH_yourusername schematic page to open the schematic drawing.
2. Choose menu **Place → Text.** In the Place Text window, type in the text you want to add to your schematic. For this tutorial, the author wrote “Astable Multivibrator”.

**Note:** You must type Ctrl+Enter to make a new line in this text entry field. If you only press Enter, the software will interpret your entry as clicking the OK button instead.

3. Before you click **OK**, change the font and size by clicking on the **Change** button under the Font section, then making modifications you prefer. This tutorial uses **Times New Roman** as the font style, **Bold** and **size 16**.

4. Once you have confirmed your settings for the text, choose **OK**, then **OK** again, then a text box will attach to your cursor, waiting for you to click on the schematic to place it.

5. Place the text above the schematic, then right click and choose **End Mode**.

6. Click the **Project tab** in the upper left, and then highlight the `\AMVSCH_yourusername.dsn` design file.

7. Go to **File → Save**, and save your project.

### 3.4.5 Setting Up the Printed Circuit Board

Next, you will get a PCB ready to import the schematic and footprints.

**Important Note:** You must follow the parameters in this section exactly. If you choose any options that deviate from these parameters/instructions your PCB will not be fabricated.

1. Go to the Windows Start menu icon, then click **All Programs → Cadence Release 17.2 → Allegro Products → PCB Editor**.

2. When prompted, choose **Allegro PCB Designer** then click **OK**.

3. Wait for **PCB Editor** to open.

4. Click on the **PCB Editor** menu **File → New**. A **New Drawing** window appears.

5. Choose **Board (wizard)** from the list, then name the drawing “AMVPCB_yourusername”.

6. Click the **Browse** button, then navigate to your project folder (AMV_yourusername).

7. Create a new folder inside the AMV project folder and name it “allegro” (all lowercase).

8. Double-click the allegro folder to open it, then finally, click the **Open** button.

9. Back in the **New Drawing** window, make sure **Board (wizard)** is still highlighted, and that your board name is correct (AMVPCB_yourusername.brd), then click **OK**, then the **Board Wizard** window will load.

10. Click the **Next** button until you see **Board Wizard – General Parameters** at the top of this window.

11. Choose the **Units** to be Mils, set **Size** to “A” and choose the **At the center of the drawing** radio button. Click **Next**.
12. In the **General Parameters (Continued)** window, leave the settings as they are, but select the “Don’t generate artwork films.” radio button. Click **Next**.

13. Click **Next** to go to the **Spacing Constraints** window.

14. Type “12” in the **Minimum Line width** field then press Tab key. Everything will update to 12 mils.

15. Then select the ellipses beside **Default via padstack** and the **Board Wizard Padstack Browser** window will appear.

16. In the **Board Wizard Padstack Browser** window, type in “pad35*” in the search field, then press Enter on the keyboard.

17. Select “pad35cir25d” on the list below → click **OK**. (This is how we choose the default via).

18. You will be back in the **Board Wizard – Spacing Constraints** window. Click **Next**.

19. Choose **Rectangular board** then click **Next**.

20. Leave the default values as they are. The Width and Height of the board will be 1000 mils each (1 inch each).

21. Click **Next** → **Finish**. The board will be made in the work area and should look like Figure 2.7. If you can’t see the borders, scroll up/down to zoom until you find the borders.

22. In **PCB Editor** go to menu **File → Save** to save the board.

![Figure 3.12 PCB Outline for AMV Circuit](image)

### 3.4.6 Setting Up Footprint and Padstack Search Paths
Before we can generate a net list of all the parts in the circuit for PCB layout, we must go on the PCB Editor and make sure it knows where to search for the custom footprints. Any footprints that are not placed inside the Cadence software symbols folder will not be loaded or recognized during netlist creation. So the software must be told which additional directories to search.

1. Open up PCB Editor then go to menu Setup → User Preferences → Paths → Library and choose padpath under the Preference list.

2. Click the ellipses next to padpath under the Value column to add a new pad path. The padpath Items window will appear.

3. Click the New (insert) button to add a new row to this window. Then click the ellipses button on the extreme right of the new row to bring up the Windows File Explorer. Search and find the folder inside your project folder named “AMV Footprints and Padstacks”.

4. Choose that folder to add to the list, then click the OK button.

5. Back in the padpath Items window, click OK again.

6. Click the ellipses for the “psmpath” preference and add the exact same folder to it also.

7. Once you have set those two preferences to look for your custom footprint folder in the User Preferences Editor window, click the Apply button, then click OK.

Important Note: The path should lead to the AMV Footprints and Padstacks folder you created in Chapter 5 – Learning PCB Editor, related to this AMV project tutorial. For example, the author’s path is L:\AMV_knmackey\AMV Footprints and Padstacks\.

Note: You did not have to do the folder and path setup for the previous chapter because the footprints that we used in the previous chapter were already included inside the software package. So remember this: Anytime you are using your own custom Footprints and padstacks you must use this setup process for PCB Editor and OrCAD Capture CIS to locate the footprints for your parts during netlisting.

3.4.7 Creating the Netlist to Update the PC Board

Now you are ready to update the board you just made in PCB Editor. You will translate the schematic from Capture CIS into circuit symbols that can be placed onto the PC board. The process is called netlisting.

1. Close PCB Editor if you still have it open. Choose Yes if asked to save changes.

2. Go back to OrCAD Capture CIS if it’s already open OR if it’s closed, go to Windows Start → All Programs → Cadence Release 17.2 → Allegro Products → Capture CIS, choose the first product option, then click OK.

3. To open your project go to File → Open → Project, then find your project and open it.
4. When your project is open, click on the **Project Tab** → expand the project File named “
AMV\_yourusername.dsn” → select the AMVSCH\_yourusername folder → select the AMVSCH\_yourusername page.

5. While the file (AMVSCH\_yourusername) in the hierarchy is highlighted, go to menu **Tools** → **Create Netlist**..., then the **Create Netlist** window will appear.

6. Check mark the option that says **Create or Update PCB Editor Board (Netrev)**.

7. Choose the **Input board file** to be the one you just created (AMVPCB\_yourusername.brd) by clicking on the ellipses button, then searching for the AMVPCB\_yourusername.brd file you made in an ‘allegro’ folder within your project folder.

8. Then change the output board to the same name “allegro\AMVPCB\_yourusername.brd”.

9. Make sure the settings and options are set to as shown in Figure 2.8, then click **OK**.

10. When a prompt appears, click **Okay** then the net list will be generated.

11. **Capture CIS** will automatically open **PCB Editor**, then a “Cadence 17.2 Allegro Product Choices” window will appear, asking which product to use.

12. Select the first option: **Allegro PCB Designer**, then click **OK**. The board will be opened in **PCB Editor**. We recommend saving your PCB before moving on.

You will notice that PCB Editor opened the same board you created earlier. There is no visible difference and the outlines are still present, but now this PCB has imported all the components and their footprints into the software. You will see the imported parts in the following sections.
3.5 Setting Up the PCB Editor Environment

This section shows you how to further set up the design environment color views and text in Allegro PCB Editor/Designer. You may use these settings for any PCB you design, not just the astable multivibrator. You can set up a lot of parameters in the PCB environment but color views and text width are the only ones we’ll cover in this chapter.

3.5.1 Changing Default Text Width

By default, PCB Editor uses 0 line width for the text width, but this can be a problem when generating Artwork Files. Open PCB Editor:

1. Go to Setup in the menu → Design Parameters and the Design Parameter Editor window appears.
2. Choose the Text tab at the top of this window.
3. Click the ellipses next to Setup text sizes. Now in the Text Setup window, change the Photo Width for all the text fields to 10 (these units were already in mils, when you used the board wizard), then click OK to go back to the Design Parameter Editor window.
4. Click **Apply** → click **OK**.
5. Back in the **Design Parameter Editor** window, click the **Design** tab and double check that your units are in Mils and the **Size** is set to **A** (this is the size of the work area).
6. Once you verify the units, click the **OK** button.

### 3.5.2 Creating Color Views (Silk screen, Solder mask, Copper and Design Outlines)

The color of the different PCB layers are a convenient way for you to print out the Gerber files and artwork files. You would set up the views for top and bottom copper, top and bottom solder mask and top silk screen and the outline.

**Top Copper View**

1. Go to the **PCB Editor** menu **Display → Color/Visibility** and the **Color Dialog** window will appear.
2. Click the **Off** button to the right of **Global Visibility** found on the right of this window.
3. Then check mark the left box at the intersection of **Top** and **All**, so your options choice should look like what’s shown in Figure 3.14.

4. Click **Apply**, then **OK**. You must always click **Apply** for the Color Dialog box to save.
5. Then go to menu **View → Color View Save** and the **Color View Save** window will appear.
6. Type “TOPL” in the **Save view** field, then click the **Save** button then **Close**.

The TOPL color view save file is saved in the same **allegro** folder the AMVPCB file is saved.

**All Other Color Views**

Next you would repeat this process for the subsequent layers according to Table 3.2. So go back to **PCB Editor’s Color Dialog** tool (menu **Display → Color/Visibility**) and turn **Global visibility** off, then check mark the boxes found in column 2 of the table. Then click **Apply** and **OK**, go to the **View → Color View Save** option, then save that view with the name shown in column 3 for that row. So for example, look at row #2 for the Bottom Copper layer, choose the color view shown in column 2 (all yellow check boxes). Apply that color view, then save it in the **View → Color View Save** as the file “BOTL”. Turn off all the colors again before you save another color view. Repeat these steps for the remaining rows in Table 3.2.
Table 3.2 Color View Save Layers

<table>
<thead>
<tr>
<th>Layer</th>
<th>Active Class + Subclass</th>
<th>Colorview Save Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top Copper (done)</td>
<td>Top</td>
<td>TOPL</td>
</tr>
<tr>
<td>Bottom Copper</td>
<td>Bottom</td>
<td>BOTL</td>
</tr>
<tr>
<td>Top Solder mask</td>
<td>Soldermask_Top</td>
<td>MASK_TOP</td>
</tr>
<tr>
<td>Bottom Solder mask</td>
<td>Soldermask_Bottom</td>
<td>MASK_BOT</td>
</tr>
<tr>
<td>Outline</td>
<td></td>
<td>OUTLINE</td>
</tr>
</tbody>
</table>

- **Top Copper (done)**
  - Active Class: Top
  - Subclass: Class + Subclass

- **Bottom Copper**
  - Active Class: Bottom
  - Subclass: Class + Subclass

- **Top Solder mask**
  - Active Class: Soldermask_Top
  - Subclass: Class + Subclass

- **Bottom Solder mask**
  - Active Class: Soldermask_Bottom
  - Subclass: Class + Subclass

- **Outline**
  - Overview of different geometry and components.
When your color views are finished and saved, you can navigate to the right side of the work area in PCB Editor and select the Visibility tab seen on the right, then click the dropdown box next to View and select any saved view you want to work with. Or if you want, just click the On button next to Global Visibility.

These views will be used during the artwork manufacturing in a later section to generate Gerber files. Go to the Visibility tab on the right and select the ALL view. Now you can see all the relevant color views and continue working.

### 3.6 Laying Out the Printed Circuit Board (PCB)

Now it’s time to lay out the printed circuit board in PCB Editor. If you don’t recall how to open PCB Editor, Go to Windows Start → All Programs → Cadence Release 17.2 → Allegro Products
→ PCB Editor, choose the Allegro PCB Designer option, then click OK and PCB Editor will open.

1. In PCB Editor, open your project if it’s not already open. With your project open, go to the menu: Place → Manually. The Placement window appears.
2. Choose “Components by refdes” in the dropdown field on the left.
3. Below it, check mark all the components by clicking in the Component by refdes folder’s check box.
4. Click the Hide button and you will find a part attached to your cursor.
5. Click the work area to place each component that’s attached to your cursor. If you want to rotate the part before placing it, can right click the part, then choose Rotate.

**How to Rotate a Part:** To rotate a part, right click the work area when the part is still attached to your cursor and is floating, then a dropdown menu will show up. Click Rotate then the part will stop moving and will begin rotating depending on which angle you move your cursor. When you have decided which angle you want, click once, then the part will re-attach itself to your mouse cursor and you can place the newly rotated part by clicking once on the work area.

6. If when you are done placing all the parts, you found that you placed a part in the wrong location, click-release (do not drag) the part to pick it up, then move it anywhere you like. Then click-release once to place the part in some new location.
7. Keep placing the parts until they’re all on the PCB area and look similar to Figure 3.15.
8. You may need to right click the work area and select Done (shortcut F6).
9. Be sure to save your file by going to menu File → Save then choose Yes if prompted about overwriting your file.

**Tip:** If you have your project open in Capture CIS at the same time, you can click the part on your schematic and in PCB Editor that same part’s symbol will attach itself to your cursor for placement.
3.6.1 Routing the PCB

In the previous chapter, you routed the PCB for the LED circuit using Autoroute. This time, you will route your PCB manually. Most PCBs are routed manually and engineers often swear by it, because there are many design considerations while routing a PCB that most automatic routing tools can miss.

Be aware of these general guidelines as you get ready to lay out your design:

- Place all the components onto your work area so you can plan where to put the components (proper placement accounts for 90% of the ease of routing a PCB)
- Section the components according to the sections on your schematic
- Place connectors toward the edges of the PCB
- Place components onto the PCB in a way that minimizes the trace length between parts
- Route the traces for the most important connections first (critical power and digital signals)
- Route ground connections last
- Place a copper pour for ground on the bottom of the board (if 2-layer PCB)
- Run a design rules check for all connections on the PCB
- Clean up the traces so they look more appealing

You will be done routing with the design rules check returns no errors. Now let’s route the PCB.
To start manual routing:

1. In **PCB Editor** with your project open, go to the menu **Route → Connect**. You can now click on the padstack/pin of a component, then move the mouse along the PCB area until you connect the wire to another padstack/pin.

You may notice that there are blue lines showing you where your wire should connect to. The blue lines are called Rats Nets and follow the same connections from the schematic you made earlier for the AMV.

2. Keep making connections from one pin/pad to another as you are guided by the blue lines.

3. Do not make connections for the ‘0’ net just yet. You are going to make a ground plane to deal with those connections to ‘0’ (ground).

Eventually most of the Rats Nest will disappear as you make all the connections, but sometimes it’s not possible to connect everything without crossing the wires, but you should get most of them. For example, the author routed his board as illustrated in Figure 3.16.

![Figure 3.16 Partially routed AMV PCB without '0' ground connection or vias](image)

In this tutorial we use a single via to the ground plane. So we’ll discuss the ground plane first, then placing vias.

3.6.1.1 **Placing copper pour and a ground plane**
In general, the electrical engineer should place a layer of ground copper on the bottom of a 2-sided board. The ground plane provides a solid return path for currents running through the top layer of the PCB.

The designer should make the ground plane as large as possible to reduce the overall board resistance and inductance. Here’s how to place the ground plane:

1. With your AMV PCB board open in PCB Editor, go to **Shape → Rectangular**, then you will be in that shape placement mode.
2. Click on the **Options** tab to the right of the **Allegro PCB Designer** window and choose the options shown in Figure 3.17.

![Figure 3.17 Settings for the ground plane](image)

When you have confirmed your settings above:

3. The rectangle will be attached to your cursor
4. Hover over the PCB and then click to place the copper plane as evenly inside the PCB outline as possible, then right click and choose **Done**.
5. Your PCB would look similar to Figure 3.18.
Tip: If you made a mistake placing the rectangular ground plane, you can click **Edit → Undo** (Ctrl+Z) then try placing it again.

You will notice from the figure above that there is a connection left to be made, but we have no easy way of connecting those components on the top layer. This situation calls for a via.

### 3.6.1.2 Placing Vias

A via is a hole that is plated in conductive material that connects the top layer of copper to the bottom layer of copper. If your board had multiple layers of copper, the via would also connect multiple layers vertically in the PCB.

You can only place a Via while you are routing in Route mode. So while for practice, start routing:

1. Click on the work area to start a trace, then click again to make a vertex for the trace where you will want to drop a via.

2. Right click then select **Add Via**. You will notice that a hole with a pad will appear.

**Note:** This is the same “pad35cir25d” we chose in the Board Wizard setup procedure to be the Default Via Pad stack.

**Tip:** You can also double-click to add a via, instead of right clicking then choosing Add Via.
3. Continue routing as usual to whichever layer the via took you to (the bottom layer in our case).
4. Right click then choose **Done** when you have finished routing.

| Note: | Sometimes the PCB can suddenly disappear into all black. To solve this problem, minimize PCB Editor, then maximize it or scroll up/down in the work area. |

To apply the above knowledge to our situation, if you have a single pad that needs to connect to the ground plane on the bottom:

1. Click on Route → Connect to get into routing mode.
2. Click on the pad of the transistor that has the unconnected ‘0’ pin to start routing from there.
3. Extend the trace about 100 mils from the pad.
4. Right click at that spot then choose Add via.
5. A via will be created and will immediately connect to the ‘0’ plane on the bottom layer, as seen on the right.
6. Right click the work area, then select **Done**.

If you have been routing your board exactly like the author, you have now finished routing your PCB!

You will know there are no more connections to be made when there are no more Rats Nest lines. Your finished board can have an endless number of routing path combinations. Take a look at the three versions of layout and routing the author has done in Figure 3.19 for examples.

![Figure 3.19 Routed AMV PCB version 1 (left) and this final version (right)](image)

Sometimes the routing isn’t always as good as we would like and there are many rules and guidelines on how to route a PCB. We’ll leave in-depth analysis on routing paths for PCBs to the
student for further investigation. Nonetheless, once you have finished routing, you can use a tool in PCB Editor to ‘clean up’ the traces you routed on the board.

3.6.1.3 Cleaning Up Routing

To clean up the routing, you would use the gloss feature in PCB Editor. In PCB Editor:

1. Choose the menu Route → Gloss → Parameters…. The Glossing Controller window will appear.

2. There are some pre-selected options, so keep those checked, then click Gloss at the bottom of the window.

**Warning:** Do not check mark other options in this window before click Gloss. It can cause PCB Editor to suddenly close without saving your design. This bug may be solved in future versions of Cadence 17.2 suite.

3. The Gloss tool will smoothen up the traces and angles, making the board traces look more attractive. The result is illustrated for in Figure 3.20.

Now that the routing is cleaned up you are ready to prepare the board for manufacturing.

![AMV PCB after using Gloss version 1 (left) and version 2 (right)](image)

3.7 Preparing for Manufacture

3.7.1 Generating Silk screen

The silk screen is usually white text on a PCB that shows the names of all the components and other important information. To generate Silk screen in PCB Editor:

1. Go to the menu Manufacturer → Silk screen.

2. The Auto Silk screen window will appear. In this window, you will need to the options to be just like in Figure 3.21.
3. So under the Classes and subclasses set: **Board geometry**, **Package geometry** and **Reference designator** to ‘Silk’.

4. Set the other classes to ‘None’.

5. Ensure that under the Text section, that Rotation is set to 0.

6. Uncheck the option that says “Allow under components”.

7. Click the **Silk screen** button then the silk screen will automatically be generated. It will appear in the work area as new text and lines (similar to on the right).

8. To see the silk screen clearly, change the view to “SILK_TOP” from the **Visibility** tab on the right of the work area.

Your text may be a different color from green if you have been using different color settings. Nonetheless, we’re going to change the silk screen to white using the **Color Dialog** window.

---

**Figure 3.21 Silk screen Options**

This will generate silk screen from the layers you select on the left and place the silk screen text at various angles
Changing Active Class and Subclass Layer Colors (Changing Silk screen Color)

The silk screen will show up in green by default but you can change that color to something like white, because most silk screen is printed in white in on PCBs:

1. With your PCB open in PCB Editor, go to menu Display → Color/Visibility. The Color Dialog window will appear.
2. In the Color Dialog window, select from the left area, Manufacturing.
3. Click the color white in one of the boxes from the color palette at the bottom of the window.
4. Then click the box beside the Subclass element “Autosilk Top”.
5. The silk screen text will turn white.
6. Also change Geometry → Package Geometry → Silk screen_Top to white.
7. While you are changing colors, go ahead and select Geometry on the left → Package Geometry, then select the yellow color box at the bottom from the Available colors: section, and make Pin_Number in the list above change to yellow. This change is shown on the right.
8. Be sure to click Apply, then OK.

Note: The colors selected do not save unless you click Apply, even if you click OK.

Now the color change is done. However, the board silk screen should be made easy to read. In the next section, you will make all the text read in one direction (where possible) so anyone can easily read the PCB at a glance.

Moving Text Around in PCB Editor

For readability, all silk screen text on a PCB should be facing the same direction. It's also recommended to place the text consistently above or below or left or right of the components you are working with. To manipulate the silk screen text:

1. In PCB Editor, click the Visibility tab on the right of your window.
2. In the View section, change the video to “ALL” (you would have made this color view earlier in the tutorial under Creating Color Views (Silk screen, Solder mask, Copper and Design Outlines)).
3. With your PCB open in in PCB Editor, right click the work area. Select Super Filter → Text. This makes it so that you can only select text on the work area.
4. Click-hold and drag an instance of the silk screen text that was generated for the auto silk layer (for example, grab R4) and while still holding the left mouse button, right click at the same time to bring up some options.

5. Select Rotate, then you can rotate the text, just like you rotated the parts when placing them.

6. Once you have rotated the text to an angle you like (upright is best), click-release and now the text will stay attached to your cursor from this point on until you click-place it.

7. Place the text as close to its respective part as possible without covering any other text, pads or parts. It can get tricky, but it’s doable.

8. Have the silk screen text make it clear which part it is referring to. In general you can achieve such clarity by putting the text right next to the part.

9. Also place the text above the part, where possible.

10. Repeat the same steps to move all text reference designators to appropriate locations.

11. When you are done placing the text where they should go, change your Visibility to SILK_TOP. Your PCB may end up looking like Figure 3.22.

Figure 3.22 Silk screen with corrected text positions
3.7.1.1 Adding (Silk screen) Text to the PCB

You will also need to add some text that includes your name, the date and the name of the circuit you just made. To add text:

1. With your PCB open in PCB Editor, change the Visibility to ALL.
2. Now select menu Add → Text.
3. Look at the Options tab on the right of the work area.
4. In the Active Class and Subclass section, click the first dropdown bar and choose Manufacturing (this is the Class).
5. Then click the second dropdown bar and choose Autosilk Top (this is the Subclass).
6. Put the text block size to 1.
7. Now click on the work area where you want to place the text. This is where you will place information about you and your PCB.
8. Type your 1) first and last name, 2) username, 3) “Astable Multivibrator” then 4) date in this format MM/DD/YY on to the board where you have space.
9. Then right click and choose Done.
10. Move the text around if needed (by click-holding and dragging the text) so that no components will be hiding it when the PCB is assembled.

Your board may end up looking similar to Figure 3.23.
Once you finish the silk screen text, you are ready to generate their Artwork (Gerber) Files.

### 3.8 Generating Artwork (Gerber) and Drill Files

#### Artwork (Gerber) Files

1. In **PCB Editor**, go to menu **Manufacture → Artwork**. The **Artwork Control Form** window will open. You will also see two pre-loaded artwork film folders, **BOTTOM** and **TOP**.

2. Now you will make use of the color views to add more artwork layers. While the **Artwork Film Control** window is open, click on the **Visibility** tab to the right of the **PCB Editor** work area.

3. Choose the MASK_TOP view to only see the top solder mask of the board.

4. Then right click on one of the folders inside the **Artwork Control Form** window and choose “Add”.

5. Type the name of the color view exactly. In this case, it’s “MASK_TOP” then click **OK**. The current view (solder mask) will be added and will create a **MASK_TOP** folder in the **Artwork Control Form** window.

6. Repeat the previous three steps to add “MASK_BOT” layer, “SILK_TOP”, and “OUTLINE”. No need to add the TOPL or BOTL layers or ALL layers because those will already be generated.
7. Back in the **Artwork Control Form** window, check mark **BOTTOM** and **TOP** and the remaining folders. These are all called film folders OR you can click the **Select all button**.

8. Highlight the **BOTTOM** film folder name, then change its **Undefined line width** value (on the right area inside the **Artwork Control Form** window) to 5 (mil), making sure to press the Tab key (or clicking on another field after entering ‘5’) to update the field.

9. Repeat the previous step with the remaining folders, making all their **Undefined line widths** to be 5 mils as well.

10. Now click the button at the bottom that says **Apertures → Edit → Auto → Without rotation**, then 36 new apertures should fill this **Edit Aperture Stations** window if this is your first time doing this step.

11. Click **OK → OK** and you will be back in the **Artwork Control Form** window.

12. Go to the **General Parameters** tab in this window.

13. Change the suffix field to “_yourusername”. For example, the author’s username is “knmackey”, so the author would type “_knmackey”.

14. Go back to the **Artwork Film Control** tab then check mark all the layers again if needed.

15. Finally, click the **Create Artwork** button. Choose “Yes” if prompted about using the DESIGN_OUTLINE and CUTOUT subclasses.

   **Note:** The software believes you are not using the proper subclass, but if you look inside the OUTLINE folder, you indeed are using the correct subclass.

16. The artwork Files will be generated, then placed inside the ‘allegro’ folder inside your project folder, so click **OK** in the **Artwork Control Form** window to finish.

   **Note:** The ‘allegro’ folder also houses the “AMVPCB_yourusername.brd” File for this board.

When the artwork files are generated, there are usually errors/warnings that show up in a View of file: photoplot output window, but most of the times it turns out fine, so just close it. Now that the artwork files have been generated, it’s time to generate the drill file.

**Drill File**

1. With your PCB open in **PCB Editor** go to menu **Manufacture → NC → NC Drill**. The **NC Drill** window will open.
2. Click the **NC Parameters…** button to open the **NC Parameters** window.
3. Checkmark **Leading zero suppression** and **Enhanced Excellon format**, then click **Close**.
4. Back in the **NC Drill** window, set the **Root file name** to AMVPCB_yourusername.drl.
5. Change the scale factor to 1, checkmark **Auto tool select** and **Optimize drill head travel**.
6. Uncheck **Separate files for plated/non-plated holes** and uncheck **Repeat codes**.
7. Click the **Drill** button then a drill file will be generated in your “allegro” folder (you will only see a progress bar appear then disappear after a “Successfully Completed” status).
8. After the drill file has been generated, click **Close** in the **NC Drill** window.
9. At this time, definitely save your project by going to the menu **File → Save**, then click **Yes** if prompted about overwriting the file.

### 3.9 Generating Documentation

#### 3.9.1 Photoplot of PCB Layers

1. With your PCB open in **PCB Editor** go to **File → Plot Setup**. The **Plot Setup** window will open.
2. Set **Plot scaling** to “Scaling factor” of 1.35, **Plot method** to “Color”, **Plot contents** to “Sheet contents”, then click **OK**.
3. In **PCB Editor** Go to **File → Plot…**. The **Print** window will appear.
4. Click the **Setup…** button and the **Print Setup** window will open.
5. You may choose a printer you prefer, but for this tutorial, we’ll go with **CutePDF Writer**.

**Important Note:** If you are using Blackmesa, Use CutePDF, not the option that says CutePDF (redirected 69), because CutePDF option will print to the Blackmesa computer if you are using Blackmesa, while CutePDF (redirected 69) will not let you print from through Blackmesa.

6. Choose your settings as desired (we’ll go with Landscape, under the **Orientation** section, but Portrait works fine, too).
7. Click **OK** to close the **Print Setup** window going back to the **Print** window.
8. Click **OK** to start the print operation. Wait for a few moments.

**Note:** If CutePDF is taking more than 5 seconds to start, click once in the work area of PCB Editor (black area), the CutePDF icon should show in the Windows Task Bar. Click the CutePDF icon if no window appears so that you pull up the **Save As** window.

9. In the **Save As** window that should appear, navigate to your project folder, then create a new folder named Documentation.
10. Navigate to the inside of the Documentation folder, name the File “AMVPCB_LAYERNAMETYPEousername”, where “LAYERNAMETYPE” is replaced with the View you currently have visible in PCB Editor.

11. Click Save to save the file.

12. In Windows File Explorer, navigate to your project folder named AMV_yourusername, then check the file you just made in the Documentation folder and see your AMV PCB schematic plot File (.pdf File) and make sure that it shows the PCB layer you intended to plot.

13. You will need to repeat this section’s instructions for each layer in your Visibility tab’s View drown list (i.e. TOPL, BOTL, MASK_TOP, etc.) and print them into separate PDF files. Be sure to check each one so they’re correct and to change their names accordingly.

3.9.2 Adding Vendor Information to Parts

According to source [3], you should include more information about your schematic parts than is provided by default in Capture CIS. In this section, you are going to attach manufacturer and vendor parts information to each of your parts on the AMVSCH_yourusername schematic.

Open the Excel Workbook that comes with this tutorial. For each part in the workbook, there is a Digi-Key Part number just above the part’s reference number. For example, R1 and R4 both have the part number “RNF14FTD4K99CT-ND”. To associate the part number with each of these parts:

1. Open your AMV_yourusername project in Capture CIS.
2. Then open your AMVSCH_yourusername schematic page and make sure all parts are visible.
3. Highlight all the schematic parts (or press Ctrl+A), then go to menu Edit → Properties, then information about all the selected items will appear.
4. Click the Parts tab in the lower left of this window to show only the parts on your schematic. You should see all the reference numbers of the parts on the far left.

**Note:** If you can’t see the reference numbers for each part, like C1 and R2, click-drag the column bar to the right until the reference numbers are revealed.

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>AMVSCHE_knmaclay : AMVSCHE_knmaclay</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>AMVSCHE_knmaclay : AMVSCHE_knmaclay</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>AMVSCHE_knmaclay : AMVSCHE_knmaclay</td>
<td></td>
</tr>
</tbody>
</table>

5. Click the New Property button in the upper left area.
6. Type “DigiKey Part Number” exactly, then click OK. A new column will appear to the far right.
7. Enter the part number for the first part into the DigiKey Part Number column. In our example, the first part is C1, so the part number is “311-1364-ND” found on the SMDs worksheet tab of the Excel file.

8. Continue entering (you can copy and paste) the part numbers from the Excel Workbook into the respective rows of the DigiKey Part Number column until your parts list looks something like Figure 3.24.

<table>
<thead>
<tr>
<th>AMVSCH_knmackey : AMVSCH_knmackey: C1</th>
<th>DigiKey Part Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMVSCH_knmackey : AMVSCH_knmackey: C2</td>
<td>311-1364-1-ND</td>
</tr>
<tr>
<td>AMVSCH_knmackey : AMVSCH_knmackey: D1</td>
<td>490-9182-1-ND</td>
</tr>
<tr>
<td>AMVSCH_knmackey : AMVSCH_knmackey: D2</td>
<td>160-1130-ND</td>
</tr>
<tr>
<td>AMVSCH_knmackey : AMVSCH_knmackey: J1</td>
<td>160-1130-ND</td>
</tr>
<tr>
<td>AMVSCH_knmackey : AMVSCH_knmackey: J2</td>
<td>952-2282-ND</td>
</tr>
<tr>
<td>AMVSCH_knmackey : AMVSCH_knmackey: J3</td>
<td>RNF14FTD4K99CT-ND</td>
</tr>
<tr>
<td>AMVSCH_knmackey : AMVSCH_knmackey: Q1</td>
<td>RNF14FTD4K99CT-ND</td>
</tr>
<tr>
<td>AMVSCH_knmackey : AMVSCH_knmackey: Q2</td>
<td>MMBT3904FSCT-ND</td>
</tr>
<tr>
<td>AMVSCH_knmackey : AMVSCH_knmackey: Q3</td>
<td>2N3904-APCT-ND</td>
</tr>
<tr>
<td>AMVSCH_knmackey : AMVSCH_knmackey: R1</td>
<td>RNF14FTD4K99CT-ND</td>
</tr>
<tr>
<td>AMVSCH_knmackey : AMVSCH_knmackey: R2</td>
<td>311-470KFRCT-ND</td>
</tr>
<tr>
<td>AMVSCH_knmackey : AMVSCH_knmackey: R3</td>
<td>311-470KFRCT-ND</td>
</tr>
<tr>
<td>AMVSCH_knmackey : AMVSCH_knmackey: R4</td>
<td>RNF14FTD4K99CT-ND</td>
</tr>
<tr>
<td>AMVSCH_knmackey : AMVSCH_knmackey: TP1</td>
<td>36-5000-ND</td>
</tr>
<tr>
<td>AMVSCH_knmackey : AMVSCH_knmackey: TP2</td>
<td>36-5000-ND</td>
</tr>
</tbody>
</table>

Figure 3.24 List of components with vendor part number

You can create any property you want for all the parts in your schematic and fill in the appropriate information just like above. For more information on how to search for component manufacturing and vendor information in general, refer to Chapter 4. The next section will show how to generate a bill of materials.

### 3.9.3 Generating a Bill of Materials

1. With your project open in Capture CIS, click on the Project tab and then the page schematic you want to create a bill of materials for. Double check to make sure that the page is highlighted. In this tutorial, the page would be AMVSCH_yourusername.

2. Click menu Tools → Bill of Materials and the Bill of Materials window appears.

3. In the Scope section, select Process selection.
4. Check mark **Open in Excel**.

5. Click the Browse button, then navigate to the Documentation folder that you created earlier.

6. Name the file “BOM_yourusername”, then click **Open** to confirm the file name and the directory.

7. Back in the **Bill of Materials** window, change the following field values:

   **Header**: Item\tQuantity\tReference\tPart\tDigiKey Part Number

   **Combined property string**: {Item}\t{Quantity}\t{Reference}\t{Value}\t{DigiKey Part Number}

8. When the fields are updated, click **OK**, then **Excel** will open and present a list of all the components in your schematic.

9. In **Excel**, choose **File → Save As** and the **Save As** window will appear.

10. You should be in the Documentation folder already. If not, then navigate to the folder within your project folder for this tutorial. Select the **Save as type**: dropdown bar where it says “Text (Tab delimited)” and change it to **Excel Workbook** instead.

11. Name the file BOM_yourusername again, then click the **Save** button. Choose **Yes** if prompted to replace the existing File.

### 3.9.4 Generating a Smart PDF of a Schematic

1. Open OrCAD Capture CIS and open your project in OrCAD Capture CIS if it’s not already open.

2. Click on the **Project** tab that says “AMV_yourusername” to show your project Files.

3. Expand the “\AMV_yourusername.dsn” folder and AMVSCH_yourusername folder.

4. Click and highlight your schematic you created the netlist from earlier (“AMVSCH_yourusername” in this case).

   **Important Note**: The schematic File AMVSCH_yourusername must be highlighted to generate the PDF, else the smart PDF won’t know which page you want to print. Also, you should have Ghostscript or Adobe Acrobat Pro installed on your machine.

5. Click menu **File → Export → PDF** and the **PDF Export** window will appear.

6. In the **Converter** field under the **Postscript Commands** section, choose the converter to be Ghostscript 64 bit/equivalent or Ghostscript /equivalent or Acrobat Distiller.

   **Note**: If you are using Blackmesa, choose Acrobat Distiller. If on another machine, you might not have Ghostscript nor Acrobat Distiller installed. In this case, you can’t generate a smart PDF.

7. In the **Converter Path** field, click the ellipses button and navigate to “c:\program Files (x86)\adobe\acrobat 11.0\acrobat\acrodist.exe” if you are using Acrobat Distiller or
to “c:\program files\gs\gs9.21\bin\gswin64c.exe” if using Ghostscript 64. Then click OK. You will notice the text at the PDF Export window go from red to green.

8. For the **Output Directory** field, under **Output Properties** section, click on the ellipses button and navigate to the “Documentation” folder you created earlier, then click **Select Folder**.

9. When those options are finished and your PDF Export window looks similar to Figure 3.25, click **OK**.

10. The PDF will be generated and will open automatically in Adobe Acrobat. This PDF is “smart” because you can click on each component to see its properties, click on the bookmarks on the left and on different components in the list to jump directly to that component on the sheet.

11. Close the smart PDF.

![Figure 3.25 PDF Export Settings for Smart PDF](image)

### 3.9.5 Generating a Regular PDF of the Schematic

If you are not able to generate a smart PDF, you can still print your schematic to a regular PDF. To generate a normal printout/PDF of your schematic:
1. Open your AMV_yourusername project in OrCAD Capture CIS. If prompted about which product to use, choose the first option in the Allegro Product selection window, then click OK.

2. After the project is opened in Capture CIS, choose the project tab in the windows midway down the software window. It should be beside the Start Page tab.

3. Then highlight the page name AMVSCH_yourusername found under the root folder of the folder hierarchy.

4. While the page is highlighted go to File → Print, then click the Setup button.

5. Then in the Print Setup window, click the dropdown next to Name: to choose the printer you want to use to generate the PDF, like CutePDF Writer.

6. Click the OK button to confirm how you want the schematic printed then click OK again and the schematic will bring up CutePDF for you to save it in the appropriate “Documentation” directory in your project folder.

3.10 Submitting Your PCB for Fabrication Check

3.10.1 Packaging the Artwork Files

1. In Windows File Explorer go to the artwork (.ART) files you created earlier in the tutorial, located in “[Folder AMV_yourusername]\allegro”.

2. While holding the Ctrl key on the keyboard, select all the files with extension “.ART” (not .ART-1) and .DRL.

3. Right click the highlighted files. Choose Send to → Compressed (Zipped) Folder. The .ZIP File will be generated with an arbitrary name and .zip and extension.

4. Click on the zip File which is generated and change it to AMVART_yourusername.

**Important note:** Some find it easier to just copy and paste the files into a new folder, then they right click the folder and zip the folder. **However, zipping the folder is incorrect.** The FreeDFM software is programmed to scan the contents in the zip file directly. Therefore, if it has to look into the zip file, then into the folder within the zip file before it can get to the art and drill Files, your zipped folder won’t be scanned properly. So the zip folder is the only main folder; that’s it.

3.10.2 How to Submit Artwork (Gerber) Files for Design Review

Now you are going to submit your Gerber Files to freeDFM.com for PCB review.

1. Open up a web browser (Chrome, Firefox, Microsoft Edge, etc.) and type in freeDFM.com. The web page will load so you can enter your PCB information.

2. Type in your University of Arkansas email address in the appropriate web forms.

3. Click the Choose File button and then navigate to the zip folder that you just created.

4. Select the zip File, then click Open, then the zip File will upload to the web page.

5. Click the Upload ZipFile button. A new webpage will load.
6. **Next** choose the layer types as shown in Table 3.3.

7. The AMVPCB_yourusername-1-2.drl File will automatically be assigned as the NC Drill.

8. Input all the requested information: for a:
   - Part #: type “AMVyourusername1inx1in.
   - Revision #: 1
   - X Dimension: 1, Y Dimension: 1
   - Layer Count: 2
   - Solder mask Sides: Both
   - Silk screen Sides: top

9. Finally click ‘no’ radio button for the ITAR option.

10. Double check that your settings are similar to those shown in Figure 3.26, then click **Submit**.

<table>
<thead>
<tr>
<th>File Name</th>
<th>PCB Layer</th>
</tr>
</thead>
<tbody>
<tr>
<td>TOP</td>
<td>Copper top</td>
</tr>
<tr>
<td>BOTTOM</td>
<td>Copper Bottom</td>
</tr>
<tr>
<td>MASK_TOP</td>
<td>Solder mask Top</td>
</tr>
<tr>
<td>MASK_BOT</td>
<td>Solder mask Bottom</td>
</tr>
<tr>
<td>SILK_TOP</td>
<td>Silk screen Top</td>
</tr>
<tr>
<td>OUTLINE</td>
<td>Drawing/Other</td>
</tr>
<tr>
<td>PROJECTNAME-1.DRL</td>
<td>Drill</td>
</tr>
</tbody>
</table>
The free DFM quote will be submitted. Just wait 10 to 30 minutes and you will receive results for your PCB via email. If you did your design well, your results should come back clean and look like Figure 3.27.
Excellent job! You just finished your second printed circuit board design. The next chapter will cover how to use Capture CIS to create schematic symbols and searching for and finding parts from electronics distributors.

**Skills Acquired**

- PCB Design flow
- OrCAD schematics development
- PCB Editor board development
- Routing a PCB

The author has completed project files here: [Astable Multivibrator – Kirsch Mackey](https://www.freedfm.com/freedfm/0024498964766511/results/summary2.htm).
4 Chapter 4 – Learning Capture CIS

LEARNING CAPTURE CIS

Objectives

1. Find parts on electronics vendors' websites
2. Be able to create parts symbols from scratch
3. Associate new properties to parts

4.1 Overview

Welcome to the Capture CIS chapter of this guide. Now that you have completed the tutorials in chapters 2 and 3, you are ready to create your own symbols. This chapter has instructions on how to search for parts through electronic components vendors and how to create your own part libraries and symbols.

For sake of continuity from the tutorials in chapters 2 and 3, this chapter will show you how to search for the LED and other components on a parts vendor website. Then you will learn how to create the LEDs used in those chapters from scratch.

4.2 Finding electronic parts for the schematic

The engineer ideally would start with a problem statement, such as “make an astable multivibrator circuit that operates at a frequency of about 4 Hz on its output voltage and blinks LEDs while doing so”. The engineer would then use circuit theory and analysis techniques from Circuits 1 and 2 to create a circuit that achieves the task.
This chapter will show you how one can select the LED for the astable multivibrator circuit that satisfies constraints involving voltage, current and cost. To demonstrate this process, let’s say you have already determined that your LEDs should not have a voltage drop greater than 3 Volts. In addition, you don’t want to spend more than $0.75 on the LED. Lastly, you want it to be reasonably sized, such as the popular 5mm (T-1 ¾) package used in the PSPICE simulation.

4.2.1 Searching Digi-Key parts

To search for a part like this, go to Digi-Key Electronics at http://www.digikey.com. Go to the appropriate category on the left menu under Products: LED/Optoelectronics > LED Indication – Discrete. There are thousands of parts to choose from, but you should enter specific filters, first.

![Image of Digi-Key parts search results]

Figure 4.1 Searching Digi-Key for parts

4.2.1.1 Filter Options

Enter the following filters when searching for parts on Digi-Key. Refer to the image above on where to find the following choices:

- Find the Clear All Selections button, then check mark the In stock option above it.
- Then under the Part Status column, select Active.
When those options above are selected, click the **Apply Filters** button, then you can really start your search based on what is now available.

### 4.2.1.2 Supplier Device Package

Now you will check to see if the part you are looking for has the packaging you want. Knowing the desired packaging from the top of your head comes with experience. Ask a fellow engineer or instructor or do an online search on most useful packages for your application.

In this guide, you will scroll to the “T-1 3/4” package found in the **Supplier Device Package** column all the way to the right.

Highlight the “T-1 3/4” package, and then click the **Apply Filters** button. That will reduce the options from over 7,000 to about a few hundred.

### 4.2.1.3 Ratings (current or voltage)

You know that you do not want the LED to have a voltage drop requirement greater than 3 Volts, so go to the **Voltage – Forward (Vf) (Typ)** column, click-drag to highlight only the values 1.6V through 2.1V in. then click **Apply Filters**.

**Tip**: You would use a similar method to select a range of acceptable currents/voltages for any part you need (e.g. voltage rating for a capacitor or power rating for a resistor).

### 4.2.1.4 Minimum Quantity

With the options low enough, find the **Minimum Quantity** column in the lists below, and then click the down arrow found there. The down arrow will search from the largest minimum quantities of a part first, and then search according to cost (oftentimes you can only order parts in hundreds or thousands).

### 4.2.1.5 Cost

The last option to look for is minimum cost. Once you have entered your entire filter and search criteria from the previous steps, click the up arrow under the **Unit Price USD** column. Notice that the least expensive LEDs with a minimum quantity of 1 comes only in green (that’s LTL-4234).

Normally you would go with the cheapest part(s) to minimize costs. However, for the tutorial, the author chose the LEDs that come in both green and red. They are sold by Lite-On Inc. that are next in line to be the cheapest and at the time of this tutorial, the **LTL-4233** is the ideal choice (in green and in the **other in red**), costing $0.36 each. Click the LTL-4233 part (green or red is fine).

In the part window, see the **Documents & Media** section and click on the link next to **Datasheet**. The datasheet will open. Save the datasheet PDF document inside a project folder of your choosing. Later in this chapter, you will be using the datasheet for part creation and making a bill of materials in **Capture CIS**.
4.3 Creating Schematic Symbols in Capture CIS

Now that you have all the information you need for your part, you can create a library to house the part and create its schematic symbol. You will make the library for the parts using Capture CIS.

4.3.1 Capture CIS Libraries

Capture CIS holds a number of pre-built parts that are stored in libraries. A library file has the .OLB extension and most of the libraries you find are included in the installation folders for the Cadence software in:

- C:\Cadence\SPB_17.2\tools\capture\library (and subsequent folders)

Many of the parts in the library files cannot be simulated and only serve as drawings. However, the “PSpice” subfolder found inside the capture library folder has parts that can be simulated. We’ll show you how to make your own LED in Capture CIS.

4.3.2 Starting a new project

First, go to Windows Start → All Programs → Cadence Release 17.2 → Allegro Products → Capture CIS, then with the Cadence Product Choices window appears, highlight Allegro PCB Design CIS L then click OK. The Capture CIS software will open. Now go to the menu and click File → New → Project.

In the New Project window, you can select Schematic or PSpice Analog or Mixed A/D. Name the project “LED” and change the location to wherever you want your project to be stored. It’s recommended to make a folder specifically for your project, named “LED” for example. When your settings are set up, click OK, then a Create PSpice Project window will appear.

In the Create PSpice Project window, select Create a blank project, then click OK. The project will be loaded in a project tab named LED.opj. Click the project tab then click the + button to the left of your “parts_yourusername.dsn” file, then click the + button to expand the SCHEMATIC1 folder to reveal the PAGE1 page. Rename the page by right clicking on PAGE1, then in the Rename Page pop-up window, type “LED” then click OK. Right click and rename the SCHEMATIC1 to “PARTS_Project_yourusername”.

4.3.3 Creating a Schematic symbol library

Now that you have created your project and page in Capture CIS, go, in the project tab hierarchy, click the Library folder. Then go to the menu File → New → Library and you will see a “\library1.olb*” file appear. Next you will save the library file in your project directory, so right click “\library1.olb* then click Save As in the dropdown menu. A Save As window will
appear. Navigate to inside the project directory “Parts Example”, then name the file LED and click the Save button. The \library1.olb* file will change to \discrete_yourusername.olb, just like one of the OLB files found in the Capture CIS parts libraries discussed in Capture CIS Libraries. Now that you have made the library, you can start adding parts to it.

4.3.4 Creating an LED Schematic symbol

You are going to add a generic LED schematic symbol to represent the LED-4233 part found on Digi-Key earlier in this chapter. So with your PARTS_Project_youusername project tab still open in Capture CIS, right click on \discrete_yourusername.olb → New Part, then a New Part Properties window will appear.

Type LED-4233 in the Name field, change the Part Reference Prefix to “D”, and set Part Numbering to “Numeric” then click OK. The Schematic Symbol drawing window will appear in Capture. Now go to the menu Place → Pin then the Place Pin window will appear. Enter “C” (for Cathode) for Name, “1” for Number, then click OK.

The first pin will attach to your cursor. Click and place the pin on the left of the symbol’s dashed box, then place a second pin on the right side, so your drawing looks like Figure 4.2, then right click and choose End Mode.

Double-click on pin 2 and a Pin Properties window will appear. Change the pin Name to “A” (for Anode), then click OK. Important Note: Remember or write down that pin number 1 is the cathode and pin 2 is the anode. Next, click-hold and drag the corners of the rectangle to make it taller and a bit wider. You will need some extra space to work with while making the symbol for the LED.

![Figure 4.2 Placed two pins for LED-4233](image)
Now go to the menu Options → Preferences → Grid Display tab → then uncheck Pointer snap to grid. Doing this step turns off the forcing the pointer to adhere to the grid on the drawing. In reality, it just makes the pointer snap to an extremely fine grid. You may see a shortcut for this option on your shortcut bar near the top of the screen as shown on the right. When you click the Snap to Grid button, it will change to red. Now that the grid is off, you can draw some lines for the LED.

**Adding a line**

![Figure 4.4 Drawn first line on LED](image)

Click on the menu Place → Line, then draw a vertical line just to the right of the “C” on the drawing, similar to Figure 4.3, then right click and choose End Mode (or hit Escape on the keyboard).

**Drawing a triangle**

Next, choose menu Place → Polyline (Y) then click-release on the center of the vertical line to start drawing a polygon in the shape of a triangle. Hold down the Shift key to draw in diagonal directions, then while holding down the Shift key, click to make the second vertex in the upper right, the third vertex on the bottom, then back to the first point to close the triangle. When the triangle has been made, right click and select **End Mode**.

![Figure 4.5 Draw triangle for LED Left is unfilled, right is filled](image)

With the triangle still highlighted (in pink) go to the menu and click Edit → Properties (or Ctrl+E) then an Edit Filled Graphic window will appear. Change the Fill Style to Solid, then click OK and your triangle will be filled in completely.
**Drawing the LED arrows**

Next you need to draw the two arrows to indicate that the diode emits light. So you will make a triangle, then a line and combine them to make an arrow, then copy those two make another arrow.

Go to the menu **Place → Polyline (Y)**, then hold down the Shift key and draw a triangle similar to the one shown in Figure 4.5. Then either hit the Escape key or right click → **End Mode**. Then while the triangle is still highlighted (pink), go to the menu **Edit → Properties** and just like the first larger triangle, change the **Fill Style** to **Solid**, then click **OK**. The triangle will be filled.

![Figure 4.6 Triangle for LED arrow](image)

Next, place a line in the same direction as the triangle by going to Place → Line, then hold down the Shift key. Click-release at the rear-center of the arrow head, then draw a line for the arrow’s body like in Figure 4.7.

![Figure 4.7 Drawn arrow body](image)

Right click → **End Mode**, then while the line is still highlighted (in pink), hold down the Ctrl key on the keyboard and select the arrow head triangle. Both the arrowhead and body will be selected. While they’re both highlighted, continue holding the Ctrl key, then click-hold and drag both highlighted components to the right. This action will create a copy of the arrow. Highlight and click-hold drag the arrows so they are placed similar to Figure 4.8.
Now that the arrows are placed, snap back to the grid by click menu Options → Preferences → Grid Display tab → check mark Pointer snap to grid. Next, add a line that connects the inside of the “C” to the large triangle’s nose and another line that connects to A, as shown in Figure 4.9.

![Diagram showing connections between C and triangle, and A and triangle](image)

**Figure 4.9 Draw a line between C and triangle and A and triangle**

**Changing the properties of the LED schematic symbol**

Now let’s change some properties about the part, like whether the numbers show on the schematic and so on. With your LED open in Capture CIS go to menu Options → Part Properties, then the User Properties window will open. Change **Pin Names Visible** to **False** and **Pin Numbers Visible** to **False**, then click OK. Drag the dashed outline’s corners closer to the LED until they’re similar to Figure 4.10, then go to menu **File → Save**. Finally, right click the library tab that says DISCRETE.OLB and select **Close**.

![Diagram showing LED with dashed outline](image)

**Figure 4.10 LED boundary fixed**

Congratulations on completing your LED-4233 part! You can look for the part and re-open the LED-4233 any time from the discrete_yourusername.olb in your “parts_yourusername” project tab’s hierarchy.
4.3.5 Placing the LED Schematic symbol

Now it’s time to use the LED-4233 part in a schematic. To place the component, all you do is double-click on the schematic page (in this case, “PARTS_yourusername”), go to the menu Place → Part, then in the part search field, type the name of your part “LED-4233”. It will appear in the list below. Hit the Enter key, then the part will be attached to your cursor.

You can press the “R” key on the keyboard or right click and select Rotate to rotate the part, then click to place as many copies you want on the schematic. You can see an example of the placed LEDs in Figure 4.11.

![Figure 4.11 Placed LED-4233s](image)

**Simulating the LEDs**

Simulating the LEDs is not possible as they are and activating simulations are beyond the scope of this tutorial/guide. For information on how to implement a PSPICE simulation with your components, you may refer to many online resources concerning SPICE simulation and implementation within OrCAD Capture.

A note on simulation: Most schematics made cannot be simulated unless you create or find the SPICE files for the parts being simulated, so not having a SPICE profile for the part is not a huge problem in the engineering design process. The engineer should be creating the schematic after already having performed circuit analysis on whether the design will work.

Feel free to use this process to create parts for your custom libraries at any time.

4.4 Adding merchant information to parts in Capture CIS

Earlier in this guide, you found the information for the green and red LED for the schematic. In the Astable Multivibrator Tutorial, you were only shown how to attach the vendor part number to the components. However, we recommend attaching more information to the parts.

For an easier time copying those parts information to Capture CIS, create a Digi-Key cart, then click the Download link under the Cart Tools > Output section on the right of your Digi-Key Shopping Cart. The website will create a .CSV file with all the parts in the cart for you to copy/paste from.
To add those properties, follow the **Adding Vendor Information to Parts** section on adding properties to your schematic parts, but in addition to adding the DigiKey Part Number property, also enter these properties.

- Unit Price
- Quantity
- PCB Footprint (already included in part properties, but must be added to BOM tool).
- Manufacturer Part Number
- Manufacturer

When you are finished adding those properties to your parts, copy and paste the information from the spreadsheet. Then when you go to generate the bill of materials, include those additional fields like you did the DigiKey Part Number field. Finally, execute the generation of the bill of materials and all your component information will be neatly placed in your BOM spreadsheet.
Objectives

1. Learn how to read a datasheet for package symbol information
2. Learn how to create package symbols using PCB Editor.
3. Learn how to order parts from Digi-Key Electronics vendor.

5.1 Resources and Materials

This part of the process requires the Excel Workbook that comes with the tutorial and can be found here – AMV Tutorial Chapter 3 Footprints Workbook. Also, the author has prepared a parts list on DigiKey Electronics’ website. A link to the parts can be found here – DigiKey Shopping Cart of AMV Parts.

Excel Workbook – Contains all information regarding the parts list, including padstack names, and footprint/package symbol names and dimensions that you will be using for the tutorial in Chapter 3 – PCB Design Project 1.

5.2 Footprint Creation Process Overview

5.2.1 Introduction to Package Symbols

First you will learn how to create the footprints and padstacks from a datasheet so that you understand the process in depth. Then you will make your first footprint, then make the remaining footprints for the astable multivibrator tutorial.
What is a Package Symbol/Footprint?

A footprint is a drawing that shows how an electronic component would attach to a PCB. The footprint incorporates much information about an electronic component, including the pins on it. The pins are called **padstacks**.

**Difference between Package Symbol (Footprint) and Padstack**

The footprint (incorporating the padstacks) shows the entirety of the package symbol and its attachment to the board, while the padstack only shows the size and shape of the pins for the part.

**5.3 What types of component packages exist?**

There are generally two type of discrete component packages you will be using – surface mount and through-hole. Most parts are packaged in both ways but some only come in surface mount packaging or only through-hole packaging.

For a visual idea of these components, see the figure below. The picture shows the cross section of a printed circuit board (PCB). The red layers on the top and bottom are copper. The material in between is some insulating material (usually FR-4 or other silicon material).

**Through-hole parts** look similar to the above part named “Component”. Through-hole parts go through the holes on the printed circuit board, hence the package name.

**Surface mount parts** are soldered and mounted directly to a copper surface and do not go through the copper.
5.3.1 Overall Process

You will use PCB Editor to start making a footprint, then use Padstack Editor to create a padstack/pin to use within that footprint. You will then finish creating the footprint and save it.

Normally you would repeat that process of making the footprint and its necessary padstacks together for every single component on your schematic, but that method is very time consuming. In this tutorial, the author proposes a slightly modified process to speed things up:

- Make the first footprint and padstack for a through-hole component first, then save it. This is so you see how the two are integrated.
- Make all the thru-pin padstacks for the remaining through-hole footprints in the Excel Workbook
- Make all the remaining through-hole footprints, making sure to attach their associated padstacks from the previous step to those footprints
- Start making a surface-mount footprint, make its surface mount padstack, integrate both, then save the first surface mount footprint
- Make all the remaining surface mount padstacks one after another until they’re done.
- Make all remaining surface-mount footprints, being sure to attach the surface mount padstacks from the previous step to these surface mount footprints.

Before going through the full process though, you must understand how to interpret a datasheet to get the dimensions for the package symbol/footprint.

5.4 Retrieving Package Symbol Information from Datasheets

All electronics components have physical characteristics that are being modeled Capture CIS, PSPICE or PCB Editor. PCB Editor contains package symbols that model the shape, size and connectors of physical components.

To understand how to model the package symbols, one must look at a part’s datasheet. The next section will cover how you can interpret a datasheet to model its packaging and physical design in PCB Editor.

5.4.1 How to read a datasheet for a package symbol (footprint)

Every electronic component has a datasheet. With that knowledge in the datasheet you will see how to model the package information of a part into PCB Editor. Let’s use the same LED from
Chapters 2 and 3 as our example and use the LED from the Digi-Key shopping cart shown earlier in this chapter.

5.4.2 What to look for in the datasheet

The device package for the LTL-4233 LED in the Digi-Key shopping cart is found on page 1 of the part’s datasheet (link). The first thing to look for is the drawing of the device, shown in Figure 5.1.

The second thing to look for is to note the primary and secondary measurement units. Oftentimes manufacturers include both inches and millimeters, with the primary units being either one. For example, the units in this datasheet are primarily in mm as indicated by Figure 5.1. The secondary units are in inches.

Important Note: Be familiar with inches (and mils) vs. millimeters. A Mil is 1000th of an inch and is much smaller than a millimeter.
5.4.3 Measurements in the datasheet

The measurement values you see on the Package Dimensions of the datasheet are usually flanked by sets of arrows. Pay close attention to where the arrows stop and where they start and which areas they’re pointing to.

Also keep the numbers in perspective and think about them realistically against your experience and common sense. For example, if you know the LED’s legs (leads) should be longer than its bulb and you read off “5 mm” for its lead length, but “25 mm” for its bulb length, then that should raise a red flag that you took measurements down by mistake.

The best way you will see how the dimensions will be related to PCB Editor’s Package Symbol Wizard tool is by example.
5.5 Incorporating Datasheet Information into PCB Editor Package Symbol Wizard

First you will open PCB Editor from the Windows Start menu by going to Start → All Programs → Cadence Release 17.2 → Allegro Products → PCB Editor. When the Product Selection window appears, click Allegro PCB Designer, then click OK. PCB Editor will open.

5.5.1 Starting a new package symbol creation

In PCB Editor, go to the menu and click File → New then the New Drawing window will appear. Click the Browse button to set the location for your LED on a personal drive or anywhere you’d like, since this is only an example. Once your folder is selected, click Open, then you will be back in the New Drawing window in PCB Editor. Now type “LED-4233_example” in the Drawing Name: field. Then in the Drawing Type: section highlight Select Package symbol (wizard), then click OK. The Package Symbol Wizard will load.

5.5.2 Setting up the package symbol parameters

When the Package Symbol Wizard window opens, you can select either TH DISCRETE or SIP. We’ll go with SIP for this example so select SIP then click Next. In the Template window, click Load Template then Next. Now in the General Parameters window, you will set the units to the same as what’s in our datasheet (Millimeter).

You can go with inches, too since that information is also provided, but for this example, we’ll go with mm. Set the Reference designator prefix to D*, because D stands for diode and an LED is a diode that emits light. Your settings will look like Figure 5.2, then click Next.

![Figure 5.2 General Parameters settings in Package Symbol Wizard for LED-4233_example](image)

5.5.3 Package dimensions and Parameters from the datasheet
This SIP Parameters window is the most important part of this wizard symbol creation process. The dimensions in this window need to match the datasheet very closely. You will receive explanations on what values are chosen for each parameter and why.

**Perspective**

The image to the left of this SIP Parameters window shows the package symbol view as if looking at the device from the top. Notice in Figure 5.3 that the leads are going in a vertical direction, whereas the datasheet has a side view and a top view that’s rotated 90 degrees from what’s in the Package Symbol Wizard.

It’s important to note that all dimensions must be entered with respect to the image shown in Package Symbol Wizard. You will fill in the parameters with this difference of perspectives in mind.

![Figure 5.3 SIP Parameters window for LED-4233_example](image)

**Number of pins (N)**

This parameter is simple. The number of pins on the LED is 2, so set this parameter to 2.

**Side Note:** If you were making the footprint for a single-pin connector, the number of pins can be set to 1.

**Lead pitch (e)**
This dimension is the distance from the center of one lead to the center of the adjacent lead. The datasheet shows 2.54 mm as the nominal distance for terminal pin spacing. So set Lead pitch (e) to 2.54 millimeters.

**Package width (E)**

This package width is perpendicular to the direction of the leads. That means it’s the dimension from rounded edge to rounded edge on the LED in Figure 5.3. Therefore, set this package width parameter to 5.60 millimeters.

**Package length (D)**

Package length is the dimension running parallel to the pin direction. Therefore set this value to 5.0 millimeters as indicated in Figure 5.3 from the datasheet.

With the units corrected in Package Symbol Wizard, select Next to go to the next window.

### 5.5.4 Selecting padstacks based on the datasheet

The leads of a component can be either thru-pin or surface mount. The PCB Editor software comes pre-installed with many padstacks ready for use. For this LED example, you will use a pre-made padstack. In later parts of this chapter, you will make your own padstack based on the datasheet information. First you will need to know what most of these padstacks are and how they’re named.

**Padstack Naming Convention 1 (inches/mils)**

The thru-pin padstacks of interest for circular holes are usually named “padXXXcirXXXd”. The first set of XXX’s indicate the diameter of the thru-pin’s pad in mils (thousandths of inches). The second set of XXX’s indicate the diameter of the thru-pin’s drill hole size in mils.

The ‘pad’ in the name indicates that the first dimension is for the pad of the thru-pin padstack and the ‘cir’ tells us that the thru-pin padstack has a circular pad size.

What that means is we’ll know which padstacks to consider for a component’s leads just by looking at a padstack’s name. Now that you know what to look for, let’s choose a default padstack for this LED in PCB Editor.

### 5.5.4.1 Choosing a default padstack in Package Symbol Wizard Padstack Browser

Continuing in the Package Symbol Wizard – Padstacks window, click the ellipses next to the Default padstack to use for symbol pins field and the Padstack Browser will appear. There are many padstacks to choose from, but we’re interested in the padstacks that will easily fit the LED’s leads.

**Choosing the correct hole size**
Normally resistors and capacitors have circular leads, making the choice of padstack hole dimensions pretty straightforward. However, the LED-4233 has square leads. That means we have to find a padstack with a hole that can fit the longest distance on the lead – its hypotenuse.

So for instance, this LED’s leads are 0.5 mm by 0.5 mm according to Figure 5.3. Therefore its diagonal is \( \sqrt{0.5^2 + 0.5^2} = 0.7071 \) millimeters. That translates to a drill hole size of at least 0.71 millimeters, then that converts to 0.0278 inches or 28 thousandths of an inch (mils). Therefore, you need a padstack whose drill hole is at least 28 mils in diameter.

For tolerance purposes then, choose a padstack that has a circular hole size of 35 mils (28 mils + 10 mils) or greater. You could go as small as 30 mils, but we want to be sure the 28 mil leads will fit, so 35 mils is our choice.

**Choosing the correct pad size**

The general rule of thumb is the pad diameter should be at least 0.020 inches (0.508 mm) larger than the drill hole size. That means you should choose a pad from the list that’s at least 55 mils (20 mils more than 35 selected in the previous section).

So, in the search bar type “pad*”, hit Enter, and see what comes up. If you scroll down, you will find a pad in the 55+ range, but the hole sizes are all less than the 35 mil size we selected. Scrolling down some more, you will find “Pad60cir35d”. This padstack works so highlight it then click OK.

Next, you will use a different padstack for pin 1 to indicate the diode’s polarity. Click on the ellipses button for **Padstack to use for pin 1**. In the Padstack Browser window, search for “*sq*”. This search looks for all padstacks with the letters ‘sq’ (for square) within the name. Select the padstack named “Pad60sq36d” then click OK. This name means the pad is square shaped and the diameter of the drill hole is 36 mils, which is close to what we need.

Back in the **Padstacks** window, click **Next** to move on. In the **Symbol Compilation** window, leave the default options, so the origin of the part is in the center of the symbol body and so the Package Wizard creates a compiled symbol, then click **Next**. Finally, the wizard shows a summary of your settings, then click **Finish** to compile the symbol.

Your symbol should look like Figure 5.4. Go to **File → Save** to save your footprint and the Command window at the bottom will let you know that a .psm file was created for your part. Close PCB Editor. In Windows File Explorer, you will find your footprint’s .dra and .psm files in the “LED-4233_example” folder you created earlier in this chapter.
Congratulations on completing this section! You learned how to interpret and translate a component’s dimensions into Package Symbol wizard. Now you are able to create almost any footprint based on the principles learned in this section. The next sections will take you through making all the footprints for the Astable Multivibrator tutorial using the other package options.

5.6 Making Through-Hole Package Symbols (Footprints)

5.6.1 Using Package Symbol Wizard and Padstack Editor

The strategy of this section is to create the entire first footprint in the AMV tutorial from scratch so that you understand the process of how a footprint is made. Then you will create all of the thru-pin padstacks for all of the remaining through-hole footprints first, just to make the process go a lot faster.

General Dimensioning Rules for Padstacks

Pad size vs drill size – In general when you are creating pad Stacks or thru-pin padstacks, you will want to make sure the thru-pin pad diameter is at least 20 thousands of an inch (0.6 mm) greater than the drill hole diameter.

Solder mask – Another rule of thumb for padstack design is to make the solder mask at least 0.2 mm larger than the width/height/diameter of the through pin pad that you just created.

Solder Paste – The last rule of thumb is to make the solder paste layer 0.6 mm smaller than the drill size if you are in millimeters. This rule may vary, depending on the shape of the pad.

5.6.2 What the footprints are for

The footprints that you will make in the following sections are intended to be associated with the parts in your astable multivibrator schematic. The AMV tutorial project will require that you use a surface mount and through-hole version of every part in the schematic, except the LEDs, header and power/ground connectors, which are all through-hole.
The Excel Workbook for the Astable Multivibrator tutorial tells you which part will be associated with which footprint. Now to make the footprints.

5.6.2.1 THD Discrete Method for Through-hole Footprints

**Through-hole Resistor (Axial)**

1. Go to Windows Start → Cadence Release 17.2 → Allegro Products → PCB Editor, then if the Cadence 17.2 Allegro Product Choices window appears, choose Allegro PCB Designer then click OK.

2. First you will create a footprint and a padstack together then integrate them. So while PCB Editor is open, go back to Start → All Programs → Cadence Release 17.2 → Product Utilities → PCB Editor Utilities → open Padstack Editor.

3. Keep both Padstack Editor and PCB Editor opened at the same time.

4. In PCB Editor, Go to File → New then the New Drawing window will appear.

5. For Drawing Type, choose Package symbol (wizard).

6. Click the Browse button, then in the pop-up window, navigate into your AMV_yourusername project folder and create a new folder inside named “AMV Footprints and Padstacks”.

7. Then enter the folder you just made (can double-click or select the Open button).

8. For File name, type/copy whatever is in the Excel Workbook provided with this tutorial for R1 (that would be “amv_res_axial”).

9. Once the name is correct, click Open, then back in the New Drawing window, click OK, then the Package Symbol Wizard will start.

10. In the first window, under Package Type select TH DISCRETE. Click Next.

11. In the Template window click the Load Template button. Click Next

12. In the General Parameters window, change both units fields to “millimeter” and then change the Reference designator prefix to R* then click Next.

13. Now you are in the TH Discrete Parameters window. Enter the dimensions found in the Excel Workbook for Terminal pin spacing (e1), Package width (E) and so on. Click Next.

14. In the Padstacks window, you are supposed to choose the default Padstack to use for the symbol pins. At this point you are going to need to create the thru-pin pad stack for this footprint before you finish this step for the footprint.

15. Keep PCB Editor open and go to Padstack Editor.

16. In Padstack Editor, select menu File → New, then the New Padstack window will appear.
17. Click the ellipses button on the right and navigate to the “AMV Footprints and Padstacks” folder you made earlier.

18. For **File name**: type the padstack name according to the information in the **Excel Workbook**. For this example, the name is “pad130mm_cir070mm”. Click **Save**.

19. Back in the **New Padstack** window, make sure the **Padstack usage**: field value is set to “Thru Pin” then click **OK**. The New Padstack window will disappear then you can start modifying the padstack in the Pad Editor window.

20. In the low left part of the Pad Editor window, change the units to Millimeter and confirm **Yes** when prompted.

21. Under the **Start** tab then the **Select padstack usage** section, select Thru Pin. Under the **Select pad geometry** section, select Circle.

22. Click on the **Drill** tab and change the **Finished diameter**: field to 0.7 (it’s in mm).
   
   a. Go to the **Drill Symbol** tab and under the **Define a drill symbol** section, set **Type of drill figure** to Diamond,
   
   b. **Drill figure width** to 0.70 and
   
   c. **Drill figure height** to 0.70.
   
   d. Your figure should look similar to the one on the right.

23. Click the **Design Layers** tab, then click the field under the **Select pad to change** section inside the table and under the **Regular Pad** column and choose the **Geometry** (bottom of window) to be Circle.

24. Change the diameter to 1.30. Then you will see the field in the table under the **Regular Pad** column change to “Circle 1.3000”.

25. Right click and copy the field under **Regular Pad** column then right click on the field below it that says “None” and choose Paste. Its field (DEFAULT INTERNALxRegular Pad) will change to “Circle 1.3000” and your images will change to those shown on the right.

26. Right click and paste again into the field below that, too (should intersect with the END LAYER row and **Regular Pad** column), until your window shows something similar to Figure 5.5.

27. Click on the **Mask Layers** tab, choose Circle for the **Geometry** section and then in the **Diameter** field, type the value that’s shown next to “solder mask_top” for this R1 part in the **Excel Workbook** (the value should be 1.5). Solder mask top is done.

28. Right click the field under the Pad column that says “Circle 1.5000” then choose **Copy →** Right click on the field just below it (for **SOLDER MASK_BOTTOM**) → **Paste**.
29. Then click menu **File → Save** and your thru pin padstack is done!

![Figure 5.5 pad130mm_cir070mm Padstack Design Layers settings in Padstack Editor](image)

Figure 5.5 pad130mm_cir070mm Padstack Design Layers settings in Padstack Editor

Now that you created the pad stack for this through-hole resistor you can go back to **PCB Editor** and you should be at the **Package Symbol Wizard - Padstacks** window.

30. Click on the ellipses under the **Default pad stack to use for symbol pins** section, then the **Package Symbol Wizard Padstack Browser** will appear. Search for the padstack you just made by typing the first few letters/numbers of the padstack name followed by an asterisk (*), then pressing the **Enter** key. The name is found in the **Excel Workbook** for R1 (should be pad130mm_cir070mm).

31. Highlight the footprint when it appears, then click **OK** and it will fill the both fields in the **Padstacks** window with the pad stack name.

32. Click **Next, Next** again, then click **Finish**.

The illustration in Figure 5.6 shows what the finished footprint for the through-hole resistor should look like. Make sure go to **File → Save** to save your package symbol and choose **Yes** if prompted to overwrite it. When it’s saved you will notice the lower left command window will confirm that the .psm file has been made.

We will follow this padstack-to-footprint creation process for all of the footprints but first let's create the remaining padstacks for the rest of the footprints to make things move more smoothly.
5.6.3 Creating Thru Pin Padstacks with Padstack Editor

**Padstack Naming Convention 2 (millimeters)**

There is a certain nomenclature that we use for the footprints and for the padstacks.

In this tutorial we've chosen to name the padstacks according to the pad diameter if it's circular, and to ensure that the dimensions are listed as well. Then we use an underscore to indicate that the drill hole is present. Then we use “cir” in the pad name to indicate that it is a circular drill hole.

The dimensions are listed in millimeters without the decimal point and then finally mm is used at the end of each of the dimensions to indicate the units. If no units are indicated, then assume the measurements are in thousandths of an inch (mils).

So for example a thru pin-pad stack with a drill hole of 0.70 mm diameter and with a pad size of 1.30 mm will be named pad130mm_cir070mm. You will notice this naming convention being followed for the entirety of the padstack creation process.

**Batch Thru-pin Padstack Creation**

For this section you will complete the remaining through pin padstacks shown in the Excel Workbook and shown in Figure 5.7 with your own guidance. If you need a reminder on the instructions, just repeat what you learned to create the padstack in the previous section.

So for each remaining padstack in the Excel Workbook, copy and paste the next padstack name into a new file with that name for example, your second padstack you’d be making would be named “amv_cap_radial”. Then you will repeat the exact same process you used in the last section to create the first thru-pin pad stack, making sure that the units are in millimeters.

**Padstack Settings to remember**

As you have done before in the previous section, make sure that every time create a new padstack in Padstack Editor that you select the Thru-pin option and set the units to mm first. Set the drill
hole size correctly (indicated by the “cirXXXmm” part of the padstack name), then set the drill symbol to a diamond shape with the same dimensions as the drill hole.

Then make sure the Design Layers are all set to circle (except for the ‘sqpad140mm_cir080mm’ padstack. It must have its pad **Geometry** and SOLDER MASK_TOP and SOLDER MASK_BOTTOM Pad shapes set to Square), whose diameter is indicated in the padstack’s name by “padXXXmm”.

Finally, set the solder mask top layers to at least 0.2 mm larger than the pad layer, as per the dimensions in the **Excel Workbook** that comes with the AMV tutorial. As you repeat the process for all of these thru-pin padstacks in the **Excel Workbook**, save them all in the same directory as the first footprint and pad stack. Then you will be ready to create the remaining footprints.

As a reference, when you are finished, your list of padstacks should look similar to Figure 5.7.

![Figure 5.7 AMV list of custom thru-pin padstacks](pad120mm_cir060mm.pad)
![pad120mm_cir060mm.pad](pad130mm_cir070mm.pad)
![pad140mm_cir080mm.pad](pad160mm_cir100mm.pad)
![pad200mm_cir140mm.pad](sqpad140mm_cir080mm.pad)

With those design rules in mind, you should be able to make all the padstacks shown in Figure 5.7. When you have verified that they’re finished, you are ready to create the remaining through-hole footprints with ease, so close **Padstack Editor**.

**STOP HERE** if you haven’t created all the padstacks. You must make the padstacks to move on.

### 5.6.4 TH Discrete in Package Symbol Wizard

You would follow the same process in **THD Discrete Method for Through-hole Footprints** you went through to create the remaining through-hole footprints. There are some slight modifications for each footprint however, so we’ll briefly walk you through each footprint.

**Creating the Footprint for the Through-hole capacitor**

1. In **PCB Editor**, go to menu **File** → **New**. In the New Drawing window, select **Package symbol (wizard)** and copy and paste the name for the radial capacitor (amv_cap_radial) from the AMV tutorial workbook.
2. Make sure that the footprint will be in the footprints and Padstacks folder then click **Open**, and in the New Drawing window, click **OK**.
3. For the package type choose **TH Discreet**. Click **Next**.
4. Then click **Load Template**, then click **Next**.
5. Change the units to **Millimeter** and change the reference designator prefix to “C*”, then click **Next**.

6. Change the terminal pin spacing what’s shown in the **Excel workbook** that comes with this tutorial then click **Next**.

7. Change the **Default padstack** to whatever is mentioned in the **Excel Workbook**.

   Note: The padstack should have been created from the previous section **Batch Thru-pin Padstack Creation**. If the padstack is not available at this point, either you didn’t save the padstack in the AMV Footprints and Padstacks folder, or you did not create the padstack.

8. Click **Next**, **Next**, then Finish.

9. Go to **File**→**Save**, then choose **Yes** if asked to overwrite the capacitor footprint.

   ![Figure 5.8 Footprint for the through-hole capacitor](image)

   Your footprint will look similar to Figure 5.8. Next you will follow a similar process using the **Single In-line Package** option to make a footprint for the test points.

### 5.6.5 Single In-line Package (SIP) in Package Symbol Wizard

**Creating Footprint for Test Point(s)**

1. Following the same process as shown in **TH Discrete in Package Symbol Wizard**, open **PCB Editor**.

2. Go to menu **File** → **New** → select **Package symbol (wizard)**.

3. Set the file name to what’s in the **Excel document** (e.g. “amv_testpoint”).

4. Click **Browse** and make sure your Footprints and Padstacks folder is selected, then click **OK**.

5. This time you will use the **SIP** method, which stands for Single In-line Package. So click the SIP radio button and choose **Next**.

6. Click **Load template** → **Next**.

7. Change the units to Millimeter and set (type in) the reference designator prefix to “TP*”.

---

**Note:** The padstack should have been created from the previous section **Batch Thru-pin Padstack Creation**. If the padstack is not available at this point, either you didn’t save the padstack in the AMV Footprints and Padstacks folder, or you did not create the padstack.
8. Click **Next**, then fill in parameter values based on the *Excel Workbook* provided.

9. Once you have updated the parameters, click **Next**.

10. Select the ellipses next to **Default Padstack**, then type in the padstack name (followed by a *) shown in the *Excel Workbook* associated with this footprint, and hit Enter key to show it in the list.

11. Click on that footprint name, then click **OK** to confirm that padstack.

12. Back in the **Package Symbol Wizard – Padstacks** window, click **Next → Next** then **Finish**.

13. Finally, go to menu **File → Save**. If asked about whether to overwrite another footprint with the same name, choose **Yes**.

![Figure 5.9 Footprint for the test point(s)](image)

The test point footprint is done and shown in Figure 5.9. Now you can go on to create the header pin’s footprint.

*Creating Footprint for the Header Pins*

Creating the header is the same as with making the test point, but it uses a different padstack.

1. Go to **PCB Editor → File → New**, then in the pop up window, choose **Package symbol (wizard)**.

2. Change the drawing name to what is provided in the *Excel Workbook* for J1.

3. Then choose **Browse** to make sure that your footprint is in your “AMV Footprints and Padstack” folder within your project folder, clicking **Open** to select the folder.

4. When back inside the **New Drawing** window with the correct file name, click **OK**.

5. Choose the **Single In-line Package option (SIP)**, then click **Next**.

6. Choose to **Load Template** then click **Next**.

7. Change the units to **Millimeter** and change the Reference Designator prefix to “J*” then click **Next**.

8. Change the **Package Symbol Wizard - SIP parameters** to the values shown in the *Excel Workbook*.
9. When you have entered all the component parameter values, click **Next**. Now you must choose the Default Padstack.

10. Click the ellipses button next to the **Default padstack** field and you will see a list of padstack names. Type in the padstack name mentioned in the **Excel Workbook** for this header footprint, then click **OK**. The Default Padstack fields will be filled.

11. Click **Next** → **Next** → **Finish**. When done, your footprint should look like Figure 5.10.

12. Go to **File** → **Save** then choose **Yes** if prompted to overwrite the file.

![Figure 5.10 Footprint for header](image)

*Figure 5.10 Footprint for header*

**Creating Footprint for the Connector(s)**

The connector uses a single pin so we’ll use the SIP method just like the previous footprint:

1. In **PCB Editor** go to **File** → **New**.

2. Select **Package Symbol (wizard)** and choose the name footprint name (amv_con1) in the **Excel Workbook** for the connector part and the appropriate “AMV Footprints and Padstacks” directory, then click **OK** to get the wizard started.

3. Again, make sure you choose **Single In-line Package** or **SIP** for the package symbol then click **Next**.

4. Load the Template, then click **Next** again.

5. Ensure that the units are in **Millimeter** and that the Reference designator prefix is J*, then click **Next** so you get to entering the part parameters’ values.

6. Use the same parameter values as shown in the **Excel Workbook** for these headers J2/J3.

7. Once you enter the parameter values, click **Next** then choose the **Default padstack used for symbol pin** to be what is shown in the **Excel Workbook**.
8. Once you click **OK** to confirm the padstack, click **Next, Next then Finish**.

9. Save the footprint (see **Figure 5.11**) and you are ready to create the LED footprint.

![Figure 5.11 Footprint for CON1 connector](image)

**Creating Footprint for the LED(s)**

This follows the same process as the SIP method, but we’ll be using two different padstacks for this footprint, as indicated on the **Excel Workbook**.

1. Open **PCB Editor → File → New**. Choose **Package symbol (wizard)** then copy and paste the name for the LEDs D1/D2 (amv_LEDT-1_075) found in the **Excel Workbook** for the AMV tutorial.

2. Make sure the footprint will be in the “AMV Footprints and Padstacks” folder you made earlier, then back in the **New Symbol** window, click **OK** to start the wizard.

3. Select **SIP**, click **Next**, then **Load template** then **Next** again.

4. Change the units to **Millimeter** and change the reference designator prefix to “D*” (for diode) then click **Next**.

5. Change the **Number of pins**, **lead pitch**, **package width** and **package length** to the parameters and values shown and the **Excel Workbook** for the LED, then click **Next**.

6. Choose the **Default packstack** to be what is in the **Excel Workbook**, then you need to change the padstack for pin 1.

7. For the padstack to use for pin 1, search for and select the square padstack you made earlier (sqpad140mm_cir080mm) in **Padstack Editor**, then click **OK**. Now this is the first time your footprint will have two type of padstacks for its pins.

8. Click **Next** and choose **Next** again, then click **Finish**.

9. The LED footprint created by the author is shown in Figure 5.12, so yours should look the same.

10. Save your footprint and choose **Yes** if prompted about overwriting the file.
However, you are not done with this part yet. All LED footprints need to show the shape of the LED’s body and the direction of the anode and cathode. So open the datasheet for this LED (find it in the Excel Workbook or click here).

5.6.5.1 Modifying a footprint (for the LEDs)

Sometimes the Package Symbol Wizard doesn’t give the exact footprint you want. This section will show you how to modify a pre-existing footprint to your needs. With your LED footprint open in PCB Editor, change the grid spacing of the work area:

1. Right click the work area and choose Quick Utilities → Grids…. Then the Define Grid window will appear.
2. Look to the right of the Non-Etch section, then next to Spacing:, change x: and y: to 0.1 and 0.1 respectively.
3. Uncheck “Grids On” in the upper left.
4. Click OK.

Now you can delete the package geometry boxes on this LED footprint and move along with finer precision in the work area.

Deleting unwanted objects on the work area

With the LED footprint open in PCB Editor:

1. Go to Edit → Delete.
2. Then click on 4 different boxes in the footprint that outline the perimeter of the footprint (look on the right. The boxes you should delete will overlap and are on the perimeter of the footprint. So do not delete the square pin or the other pin and do not delete any text) until the footprint looks like Figure 5.13 below.
3. When the boxes have been deleted, right click the work area and choose Done.
Figure 5.13 LED footprint with Package Geometry box outlines deleted.

Adding a Line to the footprint

First we’ll show you how to make multiple copies of the shapes and lines similar to Figure 5.14.

Figure 5.14 Duplicated shapes using Copy

1. To make the four lines in the picture above, go to Add → Line.
2. Look at the **Options** tab to the right of the work area (and to the right of this text) while in **Add Line** mode.

3. Set the **Line lock** values to: **Line, 90**.

4. Set **Line width** to **0.120** millimeters

5. Keep the **Line font** to **Solid**.

6. Ignore the **Active Class and Subclass:** section for now.

7. Now click (do not hold down the mouse button) on the work area and draw 1 line some distance below pin number 2.

8. Right click the work area then choose **Done**.

9. Your first line would have been placed.

**Adding an arc to the footprint**

Next we’ll show you how to make multiple copies of the arcs in Figure 5.14.

1. To make the first arc go to **Add → 3pt Arc**.

2. Look at the **Options** tab to the right of the work area (and to the right of this text) while in this mode.

3. Ignore the **Active Class and Subclass:** section for now.

4. Set **Line width** to **0.120** millimeters

5. Keep the **Line font** to **Solid**.

6. Now click (do not hold down the mouse button) on the right end of the line you drew earlier, then click on the left end of the same line. These first two points determine the end of the arc.

7. Finally, click some distance above pin 1 (ideally this distance would be the dimensions of the LED, but an estimate is fine, once the arc passes pin 1 above) to finish the arc.

8. Right click the work area then choose **Done**.

9. Your first arc would have been placed and may look like Figure 5.15.
Using Copy to copy anything

Now you are going to make duplicates of the line and the arc until you have 4 lines and 4 arcs each. As a reminder, we’re trying to make your work area look similar to below as a starting point for modifying our LED footprint.

To accomplish these multiple arcs and lines, you will use Copy. Whenever in Copy mode, you can click on a line, shape, object or almost anything, then a copy of that object will attach to your cursor. Then when you click in some new location, you will drop a copy of that object into that location. You can keep doing this indefinitely, so let’s do it.

1. In PCB Editor, go to Edit → Copy. Now you are in Copy mode.
2. Click the straight line you created earlier and place 3 copies of it arbitrarily on the work area.
3. Then click the arc and place 3 copies of said arc arbitrarily around the work area also.
4. Right click the work area and choose Done.

Now your work area will be just like and you are ready to move on.

**Changing the Class and Subclass of an Object**

When you deleted the 4 boxes at the beginning of this LED footprint modification section, you deleted all areas allocated for the LED. Now you are going replace those boxes with shapes that look like the LED, but you need to change their classes first.

To change the class and subclass of a line/shape:

1. Right click on an arc then in the dropdown menu, choose **Change class/subclass → PACKAGE GEOMETRY → [appropriate subclass]**. Make sure that each arch and each line is set to only one of each of these subclasses below.

<table>
<thead>
<tr>
<th>Package Geometry / Assembly Top</th>
</tr>
</thead>
<tbody>
<tr>
<td>Package Geometry / Place_Bound_Top</td>
</tr>
<tr>
<td>Package Geometry / Silk screen_Top</td>
</tr>
<tr>
<td>Package Geometry / Dfa_Bound_Top</td>
</tr>
</tbody>
</table>

Therefore, set one arc and one line each to the Package Geometry / Assembly Top subclass, another arc and line each be from the Package Geometry/Place_Bound_Top subclass and so on.

When you are done changing to the four subclasses above, your arcs and lines should have colors shown in Figure 5.17.

![Figure 5.17 LED arcs and lines with changed class/subclass](image)
2. Now move those arcs and lines into place by clicking on Edit → Move and moving the lines on top of one another first (until only one is seen), then placing the arcs’ legs to straddle the straight lines just like Figure 5.18 demonstrates.

![Figure 5.18 Overlapping arcs and lines for LED footprint](image)

**Adding silk screen art to a footprint**

Now you are going to add the arrow to indicate which direction the diode is facing.

3. With your LED footprint still open in PCB Editor go to Add → Line.
4. Look at the Options tab to the right of the work area (and to the right of this text) while in Line Add mode.
5. Under the Active Class and Subclass: section, choose Package Geometry → Silk screen_Top, to indicate that we want this graphic on the silk screen layer of the PCB.
6. Set the Line lock to Line, 45.
7. Set Line width to 0.120 millimeters
8. Keep the Line font to Solid.
9. Now click on the work area to draw a triangle in the center of the diode so it points downward, then right click and choose End Mode when the triangle shape is done, similar to Figure 5.19.
10. Next, add another line in parallel with the bottom horizontal line and crosses the apex of the triangle like.

11. Then draw a line perpendicular straight down from the top of the LED to the triangle like below.
12. Finally, go to File → Save and click Yes if prompted about overwriting your footprint. When you are done, your finished footprint will look very similar to Figure 5.22.

Now you can make the next package symbol (footprint).

5.6.6 Zig-Zag In-line Package (ZIP) for Through-hole Footprints

Creating Footprint for the Through-hole Transistor

We will use the Package Symbol Wizard to create the through-hole transistor footprint so:

2. In the New Drawing window select Package symbol (wizard) and use the same drawing name (amv_to-92) as found in the Excel Workbook for part Q2 in the Astable Multivibrator Tutorial.

3. Choose the AMV Footprints and Padstacks folder you have been using, then click OK.

4. In the new window, select ZIP and click Next.

**Note:** As you can tell, the ZIP package tool/method is like the SIP method, but the pins are in a staggered zig-zag pattern instead of being in a straight line.

5. Choose to Load Template then click Next.

6. Set the units to Millimeter and set the Reference designator to be “Q*”, then choose Next.

7. Set the measurement parameters as shown in the Excel Workbook, then click Next.

8. In the next window, set the Default padstack to the padstack found in Excel Workbook for your Q2 part.

9. Once you have selected the default padstack and clicked OK, you will return to the Default Padstack window. Click OK then click Next and Next again.

10. Finally click Finish, then the footprint will be loaded in PCB Editor and presented with the numbers 1, 2 and 3 going from top to bottom pins.

You must change the pin numbering according to the data sheet (part datasheet link is in the workbook), because the pin numbers on the datasheet state pin 1 should be in the center and pin 2 at the top.

![Figure 5.23 Footprint for TO-92 through-hole transistor package](image)

**Changing Pin Numbers in a Footprint**

1. To change the center pin number to 1 (instead of 2), click on the PCB Editor menu Edit → Text.

2. Click on the center pin number text and a cursor will start blinking where the number is. Type in “1” for the center pin’s number, then press Enter on the keyboard.
3. Then click on the top pin’s number, and change the pin number to “2” instead of 1.

4. Finally, go to **File → Save** to save the footprint. Choose **Yes** if prompted about overwriting the file. The final footprint will look like **Figure 5.23** when you are done.

### 5.6.7 Dual In-Line Package (DIP) for Through-hole Integrated Circuits (ICs)

This footprint is not part of the Astable Multivibrator tutorial, so you may skip this if you are only doing the Astable Multivibrator Tutorial and go to **Making Surface Mount Package Symbols (Footprints)**. If you are doing the LED Organ Tutorial, then continue in this section.

Oftentimes a design requires a chip that holds integrated circuits, such as an operational amplifier or optocoupler. In this section, you will learn how to create an integrated circuit in a DIP8 package for the LEDs Organ Tutorial Project.

1. Go to **Windows Start → All Programs → Cadence Release 17.2 → Allegro Products → PCB Editor**. When prompted in the product selection window, select the first option then click **Open. PCB Editor** will load.

2. In **PCB Editor** go to **File → New**, then a new window will load.

3. In the new window, select Package symbol (wizard) and use the same drawing name for the DIP8 component as found in the **Excel Workbook** for the LED Organ Tutorial.

4. Click the **Browse** button and choose the Footprints and Padstacks folder you have been using, as a location to save the footprint. Then click **OK**.

5. In the new window, select DIP and click **Next**.

6. Choose to load the default template and set the units to millimeters.

7. Set the Reference Designator to be U*. Choose **Next**.

8. Set the measurement parameters as shown in the **Excel Workbook** for that component, then click **Next**.

9. In the new window, select the Default padstack to be what’s in the **Excel Workbook** for the LED Organ Tutorial.

```
Important Note: If you haven’t made the padstack yet, then you will need to create and save the padstack in Padstack Editor into your Footprints and Padstacks folder first, then come back to the PCB Editor software to add it as the default padstack. Use the same methods you did for the through-hole padstack creation earlier in this chapter to generate the needed padstack or you can use a pre-made padstack. For more information on pre-made padstack go to Selecting padstacks based on the datasheet.
```

10. Once you have selected the default padstack and clicked **OK**, you will return to the **Default Padstack** window. Click **OK** then click **Next** and **Next** again, then **Finish**.
The footprint will load in PCB Editor. Save the footprint and your DIP package will be finished and ready to use in the LED Organ Tutorial.

Now that you have completed through-hole footprints, you are ready to do surface mount footprints.

5.7 Making Surface Mount Package Symbols (Footprints)

The same zig zag in line package method used to create through-hole package symbols can also create surface mount package symbols (footprints). It really just depends on the padstacks used for the package symbol. In the sections below we will show how you can use the methods for through-hole footprints to also create surface mount footprints.

5.7.1 Zig-Zag In-line Package (ZIP) for Surface Mount Package Symbols (Footprints)

So to demonstrate, we will again use the ZIP option in PCB Editor’s Package Symbol Wizard to create the surface mount sot-23 footprint for a surface mount transistor.

Creating the SOT-23 Transistor Footprint

1. Open PCB Editor. Go to menu File → New. In the new window, select Package symbol (wizard) from the list.
2. Use the name that's found in the “SMDs” worksheet tab of the AMV Excel Workbook provided with the AMV tutorial.
3. Also double-check that in the PCB Editor New Drawing window, that you click Browse and place this footprint you will make (amv_sot-23) inside your “AMV Footprints and Padstacks” folder. Then click OK to start the Package Symbol Wizard. The Package Symbol Wizard will start.
4. Choose the ZIP package method. Click Next. Load Template then click Next.
5. Change the units to Millimeter and change the reference designator prefix to “Q*” then click Next, then you will go to the Parameters window.
6. Fill in the parameters shown in the Excel Workbook (SMDs spreadsheet→Q1) then click Next.

At this point we will take a detour to create the surface mount padstack in Padstack Editor, then attach it to this surface mount footprint currently in progress. So keep PCB Editor open.

5.7.1.1 How to create a surface mount padstack in Padstack Editor

1. Go to Windows Start → All Programs → Cadence Release 17.2 → Product Utilities → PCB Editor Utilities → Padstack Editor.
2. Now go to menu File → New and a New Padstack window will appear.
3. Under Padstack usage, choose SMD pin.
4. Name the padstack the same as the associated SMD pad written in the Excel Workbook for Q1.

5. Click the browse button to save it in the AMV Footprints and Padstacks folder you have been saving to, then finally, click OK in the New Padstack window to begin making the padstack.

6. The Padstack Editor window will load (or stay loaded). First, change the units on the lower left of it from Mils to Millimeter. If asked about loss of accuracy, confirm Yes.

7. Select the Design Layers tab. Look at the bottom of the window for section that says Geometry and change the shape from None to Rectangle.

8. Choose the width and height of the rectangle according to the AMV Tutorial Excel Workbook values.

9. Click the Mask Layers tab, then change both the solder mask top and solder paste top layers to the rectangle shape. Have those layers be the dimensions shown in the Excel Workbook as well.

10. Also make sure that you maintain the exact same nomenclature for this padstack as shown in the Excel Workbook (e.g. “smd140mm_rec100m”) and finally save the padstack in the same folder as the other padstacks “AMV Footprints and Padstacks”.

Now that you have made the surface mount padstack, you will switch back to PCB Editor to finish make the sot-23 footprint using the padstack you just created. So first, close Padstack Editor:

1. Switch back to PCB Editor (should still be open), click the ellipses button in the Default Padstack section. A new window will appear.

2. Find and select the padstack you just made (by typing the “padstackyoujustmade*”) and click OK.


4. The footprint has been made, but the pin numbers need to be changed to match the datasheet for this part. The part’s datasheet can be found in the Excel Workbook.

5. So in PCB Editor go to menu Edit → Text, click on the bottom pin number, then delete it and type “2”, then press Enter.

6. Next, change the right pin to “3” and hit Enter.

7. Leave the top pin as “1”.

8. Then go to File → Save. If prompted about overwriting the file, choose Yes.

Your footprint will look like Figure 5.24.
Next you are going to create the final sets of surface mount footprints. However, before making the footprints, you will create all the surface mount padstacks first.

Then you will make the footprints that will use those just-made padstacks, just like what was done in the through-hole footprint creation process.

5.7.2 Creating Surface Mount Padstacks with Padstack Editor

In this section, you would finish create the remaining padstacks shown in the SMD tab of the Excel Workbook provided in the AMV tutorial. You will use the same method from the How to create a surface mount padstack in Padstack Editor section.

SMD Padstack Naming Convention

There is also a naming convention used for surface mount padstacks. When the padstack is rectangular/square in shape, the width is mentioned first, then the height is mentioned second in the padstack name. No decimal points are used and the units are indicated if in millimeters, but not indicated if the units are in thousandths of an inch (mils).

So for example, a rectangular padstack with a width of 1.2 millimeters and a height (if looking at it from the top bird’s eye view on a PCB) of 0.8 mm, then the padstack’s name would be smd120mm_rec080mm.

Batch SMD Padstack Creation

Now it’s time to create all the remaining padstacks. Luckily only two padstacks are left and are found in the Excel Workbook. Follow the exact same procedure you did in How to create a surface mount padstack in Padstack Editor for each padstack and save them to your “AMV Footprints and Padstacks” folder. When you have finished all the padstacks, your AMV Footprints and Padstacks folder of files should look like Figure 5.25 if you only view the .pad files.
5.7.3 SMD Discrete in Package Symbol Wizard

Creating a 1206 SMD Resistor

This surface mount resistor process is similar to the previous package symbol creation methods but this time we use the SMD Discrete option in PCB Editor Package Symbol Wizard to create the footprint.

1. For the discrete resistor open PCB Editor and then choose File → New.
2. Select the Package symbol (wizard) option, name the footprint file according to the AMV Excel Workbook and make sure it will be located in the AMV Footprints and Padstacks folder, then click OK. The Package Symbol Wizard will start.
3. This time choose SMD discrete when prompted by the Package Symbol Wizard, then, click Next.
4. Click the Load Template button. Click Next then change the units to Millimeter and change the Reference designator prefix to R*, then click Next again.
5. In this Surface Mount Discrete Parameters window, fill in the resistor measurements and parameters as per the Excel Workbook information, then click Next.
6. In the new window, choose the Default padstack to use for symbol pins as what is written in the Excel Workbook (padstack was made during Batch SMD Padstack Creation).
7. Click Next then Next again, then choose Finish.
8. Go to File → Save to save the footprint and click Yes if prompted about overwriting.
Your footprint will look similar to Figure 5.26. You will repeat this footprint creation process one more time for the surface mount capacitor.

**Creating a 0805 SMD Capacitor Package Symbol**

Just like all the other footprints until now, you would open the Allegro PCB Editor Package Symbol Wizard:

1. Go to PCB Editor, and choose menu File → New. A New Drawing window will appear.
2. Select Package symbol (wizard) from the list and fill in the name for C1 that's provided in the Excel Workbook for the AMV tutorial (e.g. “amv_cap_0805”).
3. Ensure that the file will be created inside the AMV Footprints and Padstacks folder inside your project folder.
4. Once you have confirmed the directory location, name and the wizard, click OK. The wizard will start.
5. Choose SMD Discrete, then click Next.
6. Load Template then click Next.
7. Choose the dimensions to be Millimeter, then put “C*” as the reference designator prefix, then select Next.
8. In the Surface Mount Discrete Parameters window, change the parameters to match what’s in the Excel Workbook then click Next.
9. Select the Default padstack to use for symbol pins to be what you created based on the Excel Workbook for the AMV tutorial, then click OK and the default padstack will be loaded in both fields.
10. Click Next, then Next again and finally, click Finish. The footprint will be loaded in PCB Editor.
11. Go to File → Save, then if PCB Editor asks about overwriting the file, choose Yes.

Your final footprint will look like Figure 5.27.
Now all of the footprints for the astable multivibrator are finished and you are ready to attach footprint names to parts and start the AMV PCB Layout.

The footprints you made for through-hole and surface mount devices are used in Chapter 3 – PCB Design Project 1. If you are following Astable multivibrator tutorial, then you should return to Chapter 3 - Attaching Custom Footprints to Schematic Parts at this time.
6 Building and Testing the PCB

BUILDING AND TESTING THE PCB

Objectives

1. Learn how to prototype a printed circuit board
2. Use a digital oscilloscope to debug and troubleshoot hardware
3. Practice soldering surface mount devices and through-hole devices

6.1 Overview

In this chapter, you will place the parts you receive from your instructor onto your printed circuit board. You need the following items to continue:

1. Your astable multivibrator (AMV) PCB
2. AMV circuit components
3. Soldering station + soldering iron
4. Solder flux
5. Solder
6. Safety goggles
7. Power supply
8. Oscilloscope
9. Digital multimeter with probes
10. Electrical wire cutters
11. Pencil
12. Printouts of your schematic and PCB.
The Department of Electrical Engineering at the University of Arkansas has lab stations equipped with the above items, except for pencils and paper. Your Teaching Assistant will distribute your PCB and electronics parts to you as well.

### 6.2 Populating the PCB

Soldering the components to your PCB takes a lot of preparation. Skill and technique are the main reasons for good versus poor soldering. Follow the next few sections closely to avoid a lot of trouble when soldering your PCB.

#### 6.2.1 Setting up your station and prepping your PCB

1. First and foremost, equip your safety goggles.
2. Place your PCB on a flat surface or in between Helping Hands clips to suspend the PCB in the air. Be careful that the Helping Hands clips do not make contact with metallic parts of the PCB. These clips and pads connections will cause short circuits.
3. Use the flux pen to coat the PCB in flux liquid. The flux will make it a lot easier to solder your circuit components to your PCB.
4. Turn your soldering station and iron on to 374 degrees Celsius.
5. Also turn on your solder smoke fan.
6. Clean the tip of your soldering iron then tin the tip immediately afterward with the solder at your station. Always keep the tip tinned with some solder.
7. Place the printout of your schematic in plain view but away from your PCB or soldering station.
8. Double check to make sure you have all your electronic parts.

Now you are ready to begin soldering.

#### 6.2.2 Which order to place the parts

You will solder the surface mount components onto the PCB first then you will solder the through-hole components. From experience this order is the best way to solder the PCB.

You should also test every part’s parameter that applies to it to see if that part is functioning properly. Below is the list of things to check before and after you solder it to the PCB:

1. Resistor – resistance
2. Capacitor – capacitance
3. LED – diode direction. You should also test if it lights up using pins from a power source
4. Transistor – not applicable

Once you have tested all the components and verify that they work, you are ready to solder them to the PCB.

#### 6.2.3 Soldering the parts

Use your flux pen and apply a generous amount of flux to the PCB. Turn your soldering iron on to 374 degrees Celsius while you wait for the flux to dry (takes about 10-30 seconds).
6.2.3.1 **Soldering the surface mount components**

Use a solder iron with a wide tip to solder your components, because the wider tip transfers heat quickly. Never use a small soldering iron tip, because they do not transfer heat quickly enough for normal components.

Here’s a video on how to solder surface mount components: [https://youtu.be/_6tpQE7ptqo](https://youtu.be/_6tpQE7ptqo)

6.2.3.2 **Soldering through-hole components**

As mentioned before, use a wide soldering tip, especially for through-hole components.

Watch the following video for through-hole parts: [https://youtu.be/b15MMzb_GWw](https://youtu.be/b15MMzb_GWw)

Note: Do not solder the battery clasp wires just yet. You will want to test that the board works first.

6.3 **Testing the PCB**

In general, you should always test if your power connection to your board works as soon as you are able. So before you connect the battery clasps, use a power supply in the lab to test your board.

6.3.1 **Test using a digital multi-meter**

Sometimes you can damage components when soldering them (especially transistors). So you need to test them before applying power. Use the digital multimeter to test:

- that the diodes are placed in the correct direction,
- the resistors have roughly their original resistances and
- the capacitors have roughly their original capacitance values.

That’s the majority of the testing. The transistor doesn’t have as straightforward a test so just hope that it works for now. If everything is good after your testing, let’s apply power.

6.3.2 **Test using a power supply**

Turn on a power supply in your lab.

**Setting voltage and current**

Limit the current to 0.5 A and set the output voltage to 9 Volts. Make sure the supply is not actually outputting a voltage yet though.

**Connecting to the circuit**

Connect the positive and negative clips of your power cables from the supply to the V+ and GND connectors on your PCB. If you don’t know which connectors those are, double check your schematic and PCB layout.

Turn on the output from the power supply, then the LEDs should start flashing in succession. It is common for students to not see any flashing LEDs at this point. The main reasons are usually:
- **The room is too bright to see the LEDs flashing.** Cover the LEDs with something dark and that could help you see them flashing,
- **One or more of the LEDs is backwards.** Desolder and re-solder the backwards LED.
- **One or more of the components were damaged.** Swap out the surface mount capacitor first, since capacitors tend to be sensitive to heat. Try swapping other parts as needed.
- **The design is incorrect.** The author recommends drawing a circuit diagram by hand based on the actual PCB you are trying to debug, then noticing inconsistencies between your drawing and your original schematic and layout.

If you have tested all the above conditions and your board still doesn’t work, speak with your instructor/teaching assistant.

### 6.3.3 Test using an oscilloscope

Assuming that your lights are blinking on the PCB, now is time to test the signal coming out the test points. Turn on an oscilloscope and hit Auto-Set as a starting point.

**Note:** Usually using Auto-Set this is frowned upon but in general Auto-Set can clear a lot of weird settings all at once.

Connect the oscilloscope probes to the hooks inside the test point terminals. Hit Auto-Set on the oscilloscope again and see if you get a clean waveform signal. You may see something similar to Figure 6.1.

![Figure 6.1 Astable Multivibrator output voltage on an oscilloscope](image-url)
6.4 Documenting the Results

The final stage is the fun part, where you get to prove the results of your experiment and to show off all your hard work!

6.4.1 Taking pictures of the PCB

Use a smartphone or high-resolution camera to take a photo of your working PCB. Take pictures of the PCB from the top, bottom and sides. Store those images on a computer to place into a report for later.

6.4.2 Placing pictures in a report

When you start writing your report for your instructors/teaching assistants, import your images into Microsoft Word or another word document editor. Learn how to add Captions and Cross References in your document so you can hyperlink to your pictures within the document.

As a general rule of thumb, always use high quality images that are cropped appropriately to maximize the important part of the image to the viewer. Nothing is more annoying than seeing an image in a report that’s hard to understand. Whoever the author was should just not have included the image in the first place!

6.4.3 Formatting the report

As with all reports in the undergraduate program, double check your report for spelling and grammatical errors. Treat your work professionally and others will, too. The tutorial is finished so happy engineering!
7 References

[1] Complete PCB Design by Kraig Mitzner
[2] PCB Design Guidelines – by QualiEco
[3] PCB Design Basics – QualiEco